Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Java (including SDK and JRE) on my new Windows 8 Pro 64bit. It works perfectly in IE but Google Chrome doesn't recognize Java at all. Can anyone let me know if Java works under Chrome in Windows 8? I heard it doesn't work in Windows 8? Is this true?

Is it possible to install Java plugin on Windows 8 Chrome?

share|improve this question
    
I suppose they are pushing forward the plugin-free web: msdn.microsoft.com/en-GB/library/ie/hh968248.aspx // support.google.com/chrome/answer/142064?hl=en-GB // superuser.com/questions/498693/… –  medigeek Oct 12 '13 at 13:51
add comment

2 Answers

up vote 1 down vote accepted

Yes, after my re-search. It does work, but the following restrictions apply (I am answering so it applies for future visitors):

  • Java plugin doesn't work in Metro mode, so you need to open Chrome in desktop mode.
  • If you are running 64bit version of Windows 8 Pro, then you need to install both 64bit & 32bit version of Java (yes, it is lame but I am not sure why it is so)

If you follow these steps Java works perfectly on Google Chrome under Windows 8 Pro 64bit.

share|improve this answer
add comment

I don't have windows 8, but you can try this:

http://nivesh2.wordpress.com/2013/02/03/java-not-working-in-windows-8-solved/

http://www.oracle.com/technetwork/java/javase/downloads/index.html

Solution:

Install latest version of JDK

Latest version of JRE

Notice that if you are running 32 bit browser then you must have x86 bit Java installed. So all those using x64 bit OS must install x86 bit JRE if they are using 32 bit browser as in my case this was the problem.

Both x64 and x86 JAVA can be installed simultaneously. So better install both! (i have both installed)

Now, Add the path of java compiler to the environment variable as shown below:

Open Advance System Settings > Environment Variables> System Variables.

Click New (if it doesn’t exist else Edit) : CLASSPATH (variable name), %JAVA_HOME%\jre\lib; (variable value),

Click New : JAVA_HOME (name), C:\Program Files\Java\jdk1.7.0 (value).

Click Edit in Path: in value add: %JAVA_HOME%\bin;

Save and exit.

Note ‘ ; ‘ separates one path with other just like ‘ . ‘ denotes the end of a line.’

Hope this solves your problem. Enjoy java in windows 8.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.