Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two mechanical HDD's in my computer.I run Windows on disk 0 and Crunchbang on disk 1. I always have to use elevated privileges in Crunchbang in order to copy files to the NTFS partition in disk 0.

enter image description here

As far as i know, the commands like chmod and chown , which are used for setting file permissions , only hold for file system objects. Also i know that , "In Linux everything is a file". i.e, there are special files that represent hardware devices , system information etc.. Since these special files belong to the virtual file system /dev they should be file system objects and so the commands like chown ,chmod should work on these files. I have successfully changed the owner and write permissions of the device sda by the command

chown aswin sda

where as i can neither change the owner / permissions of the mounted partition. I have tried to set the local user as the owner of the mounted partition and set permissions to read,write,execute.But , still the problem persists.

enter image description here

Am i missing something ?How to set the permission on this disk so that i can write into it without elevated privileges ?

share|improve this question
    
You probably mounted it using /etc/fstab. Check this: superuser.com/questions/320415/… –  medigeek Oct 12 '13 at 16:43
    
Did you install ntfs-3g? –  MariusMatutiae Oct 12 '13 at 16:44
    
@MariusMatutiae ntfs-3g is already the newest version. –  Ash Oct 12 '13 at 16:48
add comment

1 Answer

up vote 0 down vote accepted

You should NOT touch /dev/sd* permissions (I'm not talking about /media/sda4). If you did change them, please undo your changes and use the default permissions, because it can interfere with other programs. (I think the default owner/group are root:disk)

You have to unmount the disk first in order to change the permissions of the mount folder /media/Disk.

umount /media/Disk
chown aswin:aswin /media/Disk
mount -va

In order to mount the disk contents with a specific user/group id, you can set a specific uid/gid (User ID and Group ID) within /etc/fstab. See Linux - Mount device with specific user rights

Also, you have other solutions other than fstab, meaning GUI-based gnome environment:

gvfs-mount -d /dev/sdXY

...where it mounts the sdXY (change "X" and "Y" with the appropriate letter&number) partition and sets the user as the owner. Gnome environment also allows to click on a partition on the left side menu of nautilus (the file manager) and it auto-mounts the partition.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.