Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Siduction 64 bit (this is a Debian distro which runs off of the sid branch), and the Google Talk plugin has stopped working. My system is up to date, and I've tested both Chrome and Firefox. When I join a Google Hangout it launches correctly, but then hangs.

Looking at ~/.config/google-googletalkplugin/gtbplugin.log, I can see the following:

[000:006] Warning(clientchannel.cc:437): Could not initiate GoogleTalkPlugin connection 
[000:006] GoogleTalkPlugin not running. Starting new process... 
[000:006] Starting Flute 
[000:006] Warning(optionsfile.cc:47): Load: Could not open file, err=2 
[000:006] Warning(pluginutils.cc:267): Failed to get GoogleTalkPlugin path. Trying default. 
[000:012] Started GoogleTalkPlugin, path=/opt/google/talkplugin/GoogleTalkPlugin
[000:012] SendConnectStatus: Connect Status: 
[ 
   "f-connect", 

   { 
      "step" : "2" 
   } 
] 

[000:013] Waiting for GoogleTalkPlugin to start... 
[000:655] Starting client channel. 
[000:655] Warning(clientchannel.cc:462): Unreadable or no port file.  Could not initiate GoogleTalkPlugin connection 
[000:655] SendConnectStatus: Connect Status: 
[ 
   "f-connect", 

   { 
      "error" : -1, 
      "step" : "0" 
   } 
] 

[000:655] Warning(clientchannel.cc:437): Could not initiate GoogleTalkPlugin connection

Does anyone know how to fix this?

Thank you

share|improve this question
    
does your Chat - Telepathy Indicator Service is turned on? –  BlueBerry - vignesh4303 Oct 21 '13 at 5:30
    
How do I check this? –  oneself Oct 21 '13 at 14:36

1 Answer 1

up vote 5 down vote accepted

This turned out to be a libudev problem. It seems I had two versions installed for some reason. Removing libudev0 solved the problem. My version of chrome depended on that version, so I had to reinstall that as well.

$ dpkg --get-selections | grep -i libudev       
libudev0:amd64                                  install
libudev0:i386                                   deinstall
libudev1:amd64                                  install
libudev1:i386                                   install
$ apt-get remove google-chrome-beta
$ apt-get remove libudev0
$ dpkg -i ./google-chrome-beta_current_amd64.deb
share|improve this answer
    
The same worked for me with Gtalk plugin for Firefox nightly amd64 in Debian unstable. Just restarted FF after libudev0 removal to have GTalk fixed. –  HUB Oct 26 '13 at 7:53
    
There's a good explanation of this issue in Google forums - productforums.google.com/d/msg/hangouts/vYsaeEnXJXs/… When removal of libudev0 is not desired (breaks chrome) it seems possible to get Chrome & Talk to use libudev1: ln -s /lib/x86_64-linux-gnu/libudev.so.1 /opt/google/chrome/lib/libudev.so.0 –  Oren_H Nov 2 '13 at 13:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.