Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This seems to happen after I remote desktop into my work computer. Work computer has 2 monitors, both 1280 x 1024, running Windows 7 Pro. Home computer also 2 monitors, 1680 x 1050, and 1024 x 768, running Windows 8 Enterprise.

I connect using a single monitor with max screen size (1680x1024). Dual monitor connection has never worked as remote is only Win 7 Pro. I'll get back to this later.

The Problem: I am trying to connect to the work computer at various resolutions and keep getting an issue with the screen edge. Programs will maximize to full height and only partial width. The right screen edge seems to be responding about 275 pixels left of the right screen edge. If I move programs over to the right, they will snap at this point as well.

I had a similar problem more often when I was attempting to use dual monitors with /span option. However, it was happening in reverse. I would go into work and it would happen on the left side of the left monitor (right monitor is main at work if that makes a difference).

However, now it is happening through the remote connection.

I saw another post that seems similar, Window maximization sizes wrong after RDP session, but that didn't seem to help in my case.

I would like to 1. Learn what is causing this 2. Figure out how to fix it without having to restart the computer. (I haven't checked if logging off and on fixes it).

share|improve this question
    
First, what version of rdp are you using? Click the computer icon in the upper-left corner of the title bar, and then click About. –  Logman Oct 12 '13 at 21:44
    
version 6.2.9200 –  user1519402 Oct 16 '13 at 1:51

1 Answer 1

After you update your Windows 7 to the latest MSTSC, (though it should have it from Win7's SP1), you can set the RDP connection to properly use both monitors, by opening Remote desktop & choosing the subject connection, click the Options button > Display tab, checkmark "Use all my monitors ..."

But set the monitor sizes to match what's in the office, as otherwise it will move things around, change resolution, etc. trying to accommodate the difference.

share|improve this answer
    
Thanks for your comment. Windows 7 isn't the client mstsc. Windows 8 is and it is the most current. What I have read is that Windows 7 Pro as the remote computer will not allow multiple desktops. If you have read differently, could you provide an article? Also, do you know of a way to reset the screen edges? I have looked through the registry and online and have not been successful. The only thing I have found that works is logging off and back on. –  user1519402 Oct 13 '13 at 18:11
    
I aplogize; you did say Windows 8 Enterprise for the local (client) system. Re. the Win7 multiple-monitor changes, you have to use the Remote Desktop protocol update at support.microsoft.com/kb/2592687 . The screen edges are changing due to the resolution changes; change the resolution to something else & back instead of logging out & back in. –  Debra Oct 13 '13 at 18:16
    
I tried the RDP update, but it was already installed. With regard to changing the resolution, tried that several times and several different ways. Also tried searching the registry, I haven't been able to find anything. It's a weird problem. I'd be happy to try any other suggestions. Thanks for trying. –  user1519402 Oct 16 '13 at 1:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.