Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up a new user in a Win7Pro computer. The computer has HP ProtectTools enabled.

I cannot set the password from within HP ProtectTools or the User Accounts control panel, when logged in either as myself (administrator) or as the new user. I also cannot use net user <newuser> <newpasswd> from an admin-level command prompt, nor can I use the Local Users and Groups pane of the Computer Management dialog.

Whenever I try to do set the password in any of these ways, the dialog or command prompt freezes. For Control Panel and ProtectTools, the dialog turns 50% white, and mouse starts spinning. For cmd and Computer Management, I get the helpmsg 2245:

The password does not meet the password policy requirements. Check the minimum password length, password complexity and password history requirements.

However, the Local Security Policy administrative tools applet has Password Policy set to:

  • Enforce password history: 0 passwords remembered
  • Maximum password age: 0
  • Minimum password age: 0 days
  • Minimum password length: 0 characters
  • Password must meet complexity requirements: Disabled
  • Store passwords using reversible encryption: Disabled

In short, there should be no requirements.

Why do I get this message, and how can I resolve it?

share|improve this question
    
Can you try uninstalling HP ProtectTools? –  Hefewe1zen Oct 13 '13 at 2:34
    
@Hefewe1zen I use ProtectTools extensively for fingerprint authentication and pre-boot security. –  WChargin Oct 13 '13 at 2:37
    
Is this machine logged onto a domain? This will often change the way users are added/edited. If so, put the machine in a workgroup and restart, as this will change the way users are created/changed. –  root Oct 13 '13 at 2:55
    
@root It's in the default WORKGROUP workgroup. –  WChargin Oct 13 '13 at 3:42
    
@WChargin It may be interfering somehow with windows, I would try removing it to see what happens, you can always reinstall. Also are you using default US keyboard layout? –  Hefewe1zen Oct 13 '13 at 15:13
show 1 more comment

1 Answer

I've just taken a look at the Password Policy on my computer (Win 7 Ult 64-bit) and even though I am never prompted to change my password, the value of Maximum password age is set to 42 (default). I know that when it is set to 0, a users password will never expire, so you should be having no problems settings a password.

I've also tried with the value set to 0 and I haven't been able to replicate your problem. You could try changing the value to something other than 0 and then changing it back to 0 and see if that helps. Or you could change the value to an x number of days and tick the Password never expires option when you create a user to bypass that setting.

Finally, you could try setting a password that meets the complexity requirements as the Group Policy Object may not be applying the settings properly.

share|improve this answer
    
It was actually originally set to 42 but I changed it to 0 prior to posting this. The password I'm trying to set does have uppercase, lowercase, numeric, and special characters, and is ten characters long with a search space size of 6x10^19. –  WChargin Oct 13 '13 at 17:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.