Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A quick note beforehand: I've also had this happen in Leopard on my old iBook G4.

Just got my lady a new Macbook, and we have an intermittent problem with the firewall. There's almost nothing installed on the laptop, it's about 4 days old.

The whole thing has been working fine so far but it just now decided to block any and all websites - nothing loads at all. I recognised this problem from my own laptop a few months ago (running Leopard). We disabled the firewall - all browsing suddenly worked again, and we've just now re-enabled it. It appears to be working fine again now.

Has anyone had this happen before, or know what's causing it? I can't seem to turn up anything, anywhere. Google has failed me!

share|improve this question
    
The odd things is: this application firewall only blocks incoming connections. Outgoing connections (and their responses) are typically all allowed. And things like browsing, and receiving or sending email, are all initiated by outgoing connections. (See superuser.com/questions/62878/do-i-really-need-a-firewall/… for some details, but those won't help you.) –  Arjan Nov 4 '09 at 23:03
    
Under Advanced... in the Firewall Options, what do you have turned on? Additionally if you open up Console and look for the item ipfw.log under /var/log - is there anything listed? –  Chealion Nov 5 '09 at 5:48
    
Settings were defaults as far as I know, I just hit the 'start' button. At work at the moment, so I'll have to get back to you on the contents of the log! –  robotmay Nov 5 '09 at 13:13
    
In Console.app, also check appfirewall.log under /private/var/log. Look for items that have been blocked. –  fideli Jan 4 '10 at 15:00

2 Answers 2

it's not clear this is a firewall issue. unless you've installed something that blocks outgoing connections, i can't think of anything in a default leopard install that kills web browsing in this way.

first, make sure under your sharing preference pane that you've disabled internet sharing. that service sometimes does funny things to web browsing.

second, make sure your connection is working when you are having problems. try to ping www.google.com to see if that works. then try to ping 8.8.8.8. if the www.google.com fails, but 8.8.8.8 doesn't, you have a bad dns. switch to http://code.google.com/speed/public-dns/ or some other public dns.

share|improve this answer

Well, I have had similar issue. (leopard) It came one day, out of the blue. Just like that, I was unable to get my IP address attributed by the DHCP of my lab. (I had fix IP address in 150.xxx.xxx.xxx) instead I was getting 192.168.xxx.xxx.

Turned out it was the stealth mode that was screwing up my connexion. After this incident, I was unable to activate stealth mode anymore without getting this issue all over again. I tried it several times during the next few days.

However, a few month later, I tried to activate stealth mode again, and it worked fine.... Weird ?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.