Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

IMPORTANT: I don't have root access to machine I'm working on. I installed otf font in my home directory using http://tacticalvim.wordpress.com/2010/01/17/installing-fonts-in-your-home-directory-on-fedora-12/ fc-list lists the font. However when I try to set this font as terminal font: Right Click -> Edit Current Profile -> Font It doesn't list the font I recently installed.

Can you guys help me with it?

[EDIT]: It turns out I had to restart terminal to have font listed.

However why does preview for font look like rectangles and letters are smashed together? -- Never mind it was probably because of mucking around too much. Deleted ~/.fonts, recreated it, copied the font and ran fc-cache.

I now have working Inconsolata font in terminal. Thank you all :)

share|improve this question
    
If it isn't listed in the terminal font list, then the font is not a monospaced font, as those are the only ones listed. Or at least doesn't say that it is one. This could be fixed with fontforge but if the font isn't actually a monospaced font, the results would not be good. –  Dan D. Oct 13 '13 at 9:49
    
thanks, I just checked and it is mono space font. I'm trying to install and use "Inconsolata" font –  wisemonkey Oct 13 '13 at 14:49
    
Are you using Fedora? –  Braiam Oct 13 '13 at 18:08
    
it is a red hat 5.8 server –  wisemonkey Oct 13 '13 at 20:24

1 Answer 1

Shouldn't you be using the RHEL instructions, rather than fedora's? See here:http://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-x-fonts.html

share|improve this answer
    
Thanks, I just looked at RHEL tutorial. It is same as Fedora tutorial. In any case I followed re-did those steps: 1. copy font.otf to ~/.fonts directory. 2. Executed fc-chace /home/$USER/.fonts Here are few things to notice: I can see the font listed under System->Preferences->Fonts but not in Terminal font list –  wisemonkey Oct 17 '13 at 0:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.