Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

hope your can help, this problem is really annoying and I can't find an answer.

I use Firefox with personal profile "FFbeta", which I start using command line parameters C:\Program Files (x86)\Firefox5\firefox.exe -P "FFbeta" -no-remote. When I try to open links from thunderbird, instead of opening them in the running FFbeta instance, a new default profile Firefox starts.
The Win7 default programs settings allow only to set a program for handling a protocol but without command line parameter. I tried adopting the answer in Adding default command line options when opening a particular filetype and edited my registry as follows:

HKEY_CLASSES_ROOT/http/shell/open/command/(default)="C:\Program Files (x86)\Firefox5\firefox.exe" -P "FFbeta" -osint -url "%1"

Unfortunatly this didn't help. Is there another place in the registry I need to edit? Or is there another way to achieve the desired behavior?

share|improve this question

1 Answer 1

You need to change the default action in Thunderbird, which is not done through the registry. There is a very good explanation here: http://kevinlocke.name/bits/2012/07/18/thunderbird-default-browser-linux/

Essentially, the information is stored in the "mimetypes.rdf" file, which is usually found in the Thunderbird program directory \defaults\profile.

Since you can't just add an action, you have to do it with a similar workaround process as described. Depending on version of Tbird, in Windows you may use Tools > Options > Advanced > and click on the "Config Editor" button on the General tab, instead of the cited "Edit -> Preferences -> Advanced -> Config Editor...."

The rest of it should follow:

  • force Tbird to prompt with the config change to "network.protocol-handler.warn-external.http to true"

  • set it to open with the right program

  • edit the action to add the switches you want

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.