Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've downloaded a debian vm image for some testing: http://exploit-exercises.com/download (280mb)

It's a Debian Squeeze machine. I want to use the Belgian layout (which is AZERTY) in stead of the default QWERTY. There is no X server installed.

What I've tried (everything as root)

  • setxkbmap be -> 'command not found'

  • dpkg-reconfigure keyboard-configuration -> runs fine, but keyboard stays in QWERTY after selecting Belgium keyboard

  • dpkg-reconfigure console-data -> "'console-data' is not installed and no info is available"

  • apt-get install console-data -> package 'console-data' has no installation candidate. I also ran apt-get update and my apt list contains the debian urls.

  • edit /etc/default/keyboard manually. I then read I should restart /etc/init.d/hal, but that service doesn't exist

  • some other things I can't remember

  • locale-gen fr_FR -> It says "Generating locales", but only shows en_US.UTF-8. No fr_FR to be found.

  • dpkg-reconfigure locales The first list has all the locales where I select fr_Fr. The second screen (default locale) only gives en_US as option.

What else can I try?

share|improve this question
1  
wait, there's no X installed? is it just a linux console without a desktop manager? – medigeek Oct 13 '13 at 12:37
    
That's right, no desktop manager – Dauntless Oct 13 '13 at 13:13

I got it working by doing this:

apt-get update
apt-get install console-data

console-data appears to run automatically, so select "choose from full list" -> AZERTY

share|improve this answer

For a linux console use this command:

loadkeys fr

and it will set the AZERTY keyboard

share|improve this answer
    
loadkeys fr -> "cannot open file fr" (the same for 'be') – Dauntless Oct 13 '13 at 13:12
    
Try adding locale first: askubuntu.com/questions/89976/… – medigeek Oct 13 '13 at 14:39
    
I've added two things I tried. (I can't reboot because it's a live CD). Still QWERTY... – Dauntless Oct 13 '13 at 15:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .