Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to mount a NTFS drive with permissions set to 777 on debian. The code i have in fstab now is:

/dev/sdb2       /disk    ntfs    defaults,nls=utf8,umask=000,uid=1000,windows_names        0       0

But when using this all files get the permissions 600, anybody know whats wrong?

share|improve this question
add comment

1 Answer

You must change the umask of the user(s) writing to the directory. And BTW do NOT set execute permissions when they are not needed.

A umask is a negative mask of permissions which should be applied. By default, all files would be created with 666 and all directories with 777. With a umask of 002, for example, these become 664 and 775.

Now, how to set the umask depends on the program which actually writes the file, and whether this setting is available in its configuration file. see this explanation here: http://www.cyberciti.biz/tips/understanding-linux-unix-umask-value-usage.html

Another, less known way, would be to set POSIX ACLs to the upload directory: for this, you can use setfacl with the -d option (provided your OS, and filesystem, support it both).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.