Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently updated firmware for my WRT54g v5 router.

I have 4 computers 3 of which connect wirelessly. The fourth, my wife's, is the computer which is connected via cable to the router.

I used my computer to flash the firmware because my wife's is an older and slower computer. Now, the other two wireless computers connect fine but my computer will not connect. It hangs when trying to acquire the ip address.

I can get it to work though if I do a power reset of the router and do a repair on the wireless network adapter. It then acquires the ip address and remains connected until I shut down and restart.

I suspect something was changed during the flash but am not sure.

Here is what I have done: First I tried a system restore but that did not work.

Then I Googled the problem and tried several things.

I removed the wireless network connection in Device Manager and rebooted and created a new wireless network connection; no luck.

Then I ran the Microsoft Fixit to repair TCP/IP,that didn't work.

Then I tried netsh int ip reset c:\resetlog.txt from the command Prompt. That didn't work I then installed Microsoft TCP/IP Version 6 but that didn't work.

I then noticed the original TCP/IP was still there in Properties so I unchecked it. The wireless adapter immediately connected! However, shutting down and restarting the computer showed the same problem so I rechecked the old TCP/IP in properties.

Here is the result of the running ipconfig /all from a Command Prompt

C:\Documents and Settings\Owner>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : OWNER-096B7CFAB
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Mixed
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : hsd1.ca.comcast.net

Ethernet adapter Wireless Network Connection 8:

        Connection-specific DNS Suffix  . : hsd1.ca.comcast.net
        Description . . . . . . . . . . . : Linksys Wireless-G USB Network Adapt
er
        Physical Address. . . . . . . . . : 00-18-39-0A-24-D4
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.127
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        IP Address. . . . . . . . . . . . : fe80::218:39ff:fe0a:24d4%8
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 192.168.1.1
                                            fec0:0:0:ffff::1%1
                                            fec0:0:0:ffff::2%1
                                            fec0:0:0:ffff::3%1
        Lease Obtained. . . . . . . . . . : Sunday, October 13, 2013 2:07:59 PM
        Lease Expires . . . . . . . . . . : Monday, October 14, 2013 2:07:59 PM

Tunnel adapter Teredo Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
        Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%4
        Default Gateway . . . . . . . . . :
        NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . : hsd1.ca.comcast.net
        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface

        Physical Address. . . . . . . . . : C0-A8-01-7F
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::5efe:192.168.1.127%2
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                            fec0:0:0:ffff::2%1
                                            fec0:0:0:ffff::3%1
        NetBIOS over Tcpip. . . . . . . . : Disabled

I am stumped! I hope you can help. Thanks, Chuck

share|improve this question
    
Please explain "None of the information is the adapter you should be using" I have been using these adapters for several years now with no problem. Also, please note that 2 other computers connect with no problem. –  Chuck Bennett Oct 14 '13 at 20:03
    
Don't worry about it. My phone didn't display the content right. –  Ramhound Oct 14 '13 at 21:25
add comment

1 Answer

From the XP computer, you have to manually disconnect from the wireless network and then delete the wireless network from your list of saved networks otherwise it will keep auto-connecting with the "old" saved settings. I believe all the saved wireless networks are listed under the Properties of the wireless adapter in XP.

Then you have to connect to it as if connecting to a new network and enter the key again (you are using WPA2, right?). You can check the box to Connect Automatically and it will save this new connection.

Alternately, you can change the SSID to something different on your router and then have all the computers/devices connect to the "new" network.

share|improve this answer
    
I have already removed and recreated the wireless connection (see above) with no success and 2 other computers connect with no problem (see above) –  Chuck Bennett Oct 14 '13 at 20:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.