Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install/upgrade the version of PHP we're using on our internal server at work. Doing it from the tarball from php.net and when it comes time to run ./configure I get this error:

checking whether libxml build works... no configure: error: build test failed. Please check the config.log for details.

The config.log has this to say about libxml:

configure:22189: checking whether libxml build works configure:22216: cc -o conftest -g -O2 -fvisibility=hidden conftest.c

    -lrt -lm -ldl -lnsl  -lxml2 >&5

/usr/lib/gcc/i486-linux-gnu/4.4.6/../../../i386-linux-gnu/libxml2.so: undefined reference >to `gzopen64@ZLIB_1.2.3.3'

I've already tried doing a pretty basic update of libxml from apt and installing specifically zlib 1.2.3.3 from a tarball on http://zlib.net/fossils/ and frankly that's me all out of ideas.

EDIT Solved. Updating to the latest version of zlib rather than using 1.2.3.3 has fixed the issue.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.