Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try stuff like in my .profile:

set -o vi-tabcomplete

I get:

.profile[292]: vi-tabcomplete: bad option(s)

Does anyone know of a workaround?

share|improve this question

migrated from stackoverflow.com Nov 5 '09 at 0:56

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

It depends which flavour of ksh you have.

Older pre-ksh-93 shells support 'double-escape' auto complete - so you hit escape twice instead of tab once.

ksh-93 uses set -o viraw to enable tab completion.

Public-domain ksh, pdksh which you may be able to obtain and use if your environment permits, is the one that supports the set -o vi-tabcomplete syntax. It also supports set -o vi-esccomplete for compatibility with older ksh variants.

share|improve this answer
add comment

In Fedora 11's ksh, you get tab completion after just set -o vi

$ echo KSH_VERSION
Version M 93t 2008-11-04
$ rpm -q -a | grep ksh
ksh-20081104-3.fc11.i586
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.