Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've have tried:

apt-get update && apt-get upgrade

Also

apt-get clean 

And I still get output below:

$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 virtualbox-4.2:i386 : Depends: libdevmapper1.02.1:i386 (>= 2:1.02.20) but it is not     installed
                   Depends: libpython2.7:i386 (>= 2.7) but it is not installed
                   Depends: libqt4-opengl:i386 (>= 4:4.7.2) but it is not installed
                   Depends: libsdl1.2debian:i386 (>= 1.2.10-1) but it is not installed
                   Depends: libxmu6:i386 but it is not installed
                   Depends: psmisc:i386 but it is not installed
                   Recommends: libsdl-ttf2.0-0:i386 but it is not installed
                   Recommends: dkms:i386 but it is not installable
                   Recommends: linux-headers:i386
                   Recommends: gcc:i386 but it is not installed
                   Recommends: make:i386 but it is not installed
                   Recommends: binutils:i386 but it is not installed
                   Recommends: pdf-viewer:i386
                   Recommends: python-central:i386 but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
share|improve this question
    
How did you initially install it? –  Oliver Salzburg Oct 14 '13 at 14:52
    
Have you manually searched for the dependencies (apt-cache search lib...)? Though that is strange as I recall libpython being around by default on Ubuntu last time I used it. Your title suggests it's already installed ("can't remove nor..."). Is the current installation broken? Was it ever working? If so, what's changed between the working state and now (upgrades, clean up tools, etc)? –  nerdwaller Oct 14 '13 at 14:53

1 Answer 1

Try this:

sudo apt-get install --fix-broken 

If that doesn't work try reinstalling the package headers:

sudo apt-get install linux-headers-generic

Also, check out the answer's here:

How do I resolve unmet dependencies?

share|improve this answer
    
First command outputted: Correcting dependencies... failed. The following packages have unmet dependencies. Second outputted: linux-headers-generic is already the newest version. You might want to run 'apt-get -f install' to correct these: –  Rafael Oct 14 '13 at 15:00
    
@Rafael I updated my answer with a link to a question on the askubuntu forums. I think you need more than just "one line command" troubleshooting. –  Colyn1337 Oct 14 '13 at 15:09
    
@Colyn1337, it would be too risky to get linux-headers-generic at the first moment. –  Antony Lee Oct 14 '13 at 15:46
    
@Rafael did you check your linux distro and version and also virtual box package which customized for your linux distro ?? –  Antony Lee Oct 14 '13 at 15:47
    
Thanks for you answers, but I managed it by installing virtualbox using aptitude. –  Rafael Oct 15 '13 at 17:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.