Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently updated some packages for my emacs 24.3 under Windows, and I found strangely that the mode change messages used to be shown in minibuffer is gone, e.g., before update, when i enable or disable any minor mode, there is a message showing up in the minibuffer saying: xxx-mode is disabled. but now, this message is gone, although i can still check if the mode is disabled or enabled in the mode line. But it not as obvious by displaying a message in minibuffer.

anyone knows what can be the cause? thanks

share|improve this question

marked as duplicate by Moses, Simon Sheehan, Tog, Excellll, Mokubai Nov 4 '13 at 19:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Pretty vague description: some modes (which?), some packages (which? updated to what versions?). If you are more specific then people might be able to help you more. If you know such a package & mode, then you can also look at its code to see whether it calls message etc. If it uses define-minor-mode then a msg should be shown. You can find (most) messages logged in buffer *Messages*. –  Drew Oct 14 '13 at 18:30
    
well, actually any mode, minor or major, when i disable/enable it, there is no message showing up in minibuffer, i also checked the Messages buffer, no message about mode change there either. I believe there is certain variable of vanilla Emacs for that, which is not related to the packages that i update. –  shelper Oct 14 '13 at 18:49
    
No such variable that I know of. To inhibit logging messages one can bind message-log-max to nil, but even that does not prevent displaying messages in the echo area. –  Drew Oct 15 '13 at 1:02

1 Answer 1

seems the problem only happens on x64 version Emacs 24.3, windows, switch to 32bit version and everything is ok now

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.