Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How to fix "Windows failed to start 0xc00000e"? I have OS X + dual-partition Windows 7 disk.

Before I encountered this error, I was trying to migrate from this (older) disk to a newer one. I tried hard to only read from this older disk, but these are some guesses what could be the source of the problem:

  • I tried to shrink one of the partitions with DiskPart for 1 MB (most likely, it was #3, i.e. C)
  • as a result from the previous or otherwise, now there are two overlapping partitions which have a minor difference in starting offset (see below, marked with exclamation marks)
  • at some point this disk (connected via USB enclosure) appeared offline in Computer Management, and Windows reported "Disk Signature Collision". I simply selected "Make online", and it re-appeared

Currently, diskpart reports the following partitions:

1 - Primary  - 200MB - 512B
2 - Primary  - 46GB - 200MB  [OS X]
0 - Extended - 360GB - 46GB  [Windows data]
4 - Logical  - 360GB - 46GB  [Windows data]
3 - Primary  - 58GB - 407GB  [Windows boot]

Partition details (and volume size I added manually) are as follows:

  #   Type  Hidden? Active? Offset                  Size
  1     EE  Yes     No      512                     200MB
  2     AF  Yes     No      209 735 680             46GB
  0     0F  No      No      50 !210 013 184!
  4     07  No      No      50 !211 061 760!        360GB
     volume: 1 - D - Data - NTFS - Partition - 360GB - Healthy
  3     07  No      Yes     437 108 342 784         58GB
     volume: 2 - C - BOOTCAMP - NTFS - PARTITION - 58GB - Healthy

The tricky part is that I didn't make a complete backup (quite a challenge), and previously had a bad experience with System Restore (in other situations).

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Your disk is in a VERY dangerous state! The problem is that you've got a hybrid MBR with an extended partition. This could happen if you used a GPT-unaware tool to edit the partitions.

You should first determine whether the GPT or MBR partitions are correct -- or which GPT and which MBR partitions are correct. If the GPT partition definitions are all correct and there are no "leftover" MBR-only partitions, the solution is easy: Create a fresh hybrid MBR using gdisk or the gptsync utility that comes with rEFIt or rEFInd.

If some or all of the MBR partitions are correct and the GPT lacks some valid MBR partitions, your task is trickier: You must write down (or copy-and-paste to a text editor) the start and end points of the valid MBR partitions that have no corresponding GPT partitions, delete any invalid GPT partitions in the same range, create new GPT partition(s) that match the MBR-only partitions, and then create a fresh hybrid MBR.

You'll need to use Windows to test which MBR partitions are valid and OS X to test which GPT partitions are valid. I realize this is tricky, since Windows isn't currently booting; you may need to use a Windows emergency disk. Alternatively, you could use a FreeBSD live CD; it provides access to both MBR and GPT partitions simultaneously.

I strongly urge you to read the link in the first paragraph about hybrid MBRs. If you don't understand hybrid MBRs, you could easily dig yourself in deeper if you attempt to fix your current problem. Hybrid MBRs are ugly and dangerous at the best of time, and your current setup is teetering on the edge of something disastrous. Sorry if I sound like a prophet of doom here, but as the author of gdisk, I've gotten a few e-mails from people who've managed to trash their disks because they've used GPT-unaware partitioning tools on disks with hybrid MBRs. The result is never pretty.

share|improve this answer
    
Thanks! Do you mean that the steps "In a nutshell, I've done it as follows: ..." in apple.stackexchange.com/questions/105226/… could not in any case result in the partition setup detailed above? –  yurkennis Oct 14 '13 at 21:00
    
All three partitions (W7 boot, W7 data and OS X) seem completely readable under Windows, if disk is in connected via USB enclosure. Verifying OS X partition under OS X Disk Utility also succeeds. So how do I reliably determine if GPT or MBP partitions are correct ? –  yurkennis Oct 14 '13 at 21:44
    
Perhaps it's easier to migrate data to a newer HDD than to restore within a single HDD. Any advice on how to better approach such migration? superuser.com/questions/660114/… –  yurkennis Oct 15 '13 at 10:34
    
I don't know with certainty what caused your problem, and I'd prefer not to speculate beyond what I've already said. The "correct" partitions are those that can be read, with the caveat that the partition table entries might not match the filesystems' sizes. Migrating to a new disk is possible, but it must be done by setting up GPT partitions first and then creating a hybrid MBR. Do *not,* under any circumstances, use the standard Windows partitioning tools to modify partitions on a hybrid MBR disk. –  Rod Smith Oct 15 '13 at 17:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.