Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was trying to read an exfat file system in linux and removed the original flag of lba.then remembered I had to install exfat-utils. The drive is still exfat but now will not mount to OSx mountain lion, when looking through diskutility I can see the hdd but the partition will not mount and I can not perform a verify or repair on the drive or partition. The hdd is external. Went back into my linux vm and managed to set the flag back to lba, unfortunately no mount in mac. Also I noticed in diskutility the info for the partition says linux but for the hdd info all is available.

Cannot back up the data via shares, linux or mac, there is over 600GB of data, art work, music, docs etc and it is all important. Also have my fiancees data on there too (you guessed it, this was a manual backup disk)

Q's: how can I resolve without erasing data? How can I back up without erasing? If I can back up all data I can then erase in mac and set the partition table appropriately.

share|improve this question
    
Hi Guys, thank you for your continuing support, unfortunately I cannot boot to a live Linux CD on my machine, I've shutdown and booted holding 'C' unfortunately no go. –  Russell Clarke Oct 15 '13 at 16:26
    
Rod. S, You are right I am on VM and df shows the drive in the output however without being able to boot from the live Linux I cannot get the fdisk output you require. Do either of you have a possible solution from within the VM or direct from the Mac host? I will retry using the $ as neglected to do this, will provide an update tomorrow. Thanks again. –  Russell Clarke Oct 15 '13 at 16:30
    
Disk /dev/sdb1: 2000.4 GB, 2000398932992 bytes 245 heads, 52 sectors/track, 306674 cylinders, total 3907029166 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0xf4f4f4f4 This doesn't look like a partition table Probably you selected the wrong device. Device Boot Start End Blocks Id System /dev/sdb1p1 ? 4109694196 8219388391 2054847098 f4 SpeedStore –  Russell Clarke Oct 16 '13 at 10:48
    
dosfsck 3.0.14 (23 Jan 2023) dosfsck 3.0.14, 23 Jan 2023, FAT32, LFN Logical sector size is zero. –  Russell Clarke Oct 16 '13 at 10:50
    
When running the command sudo dosfsck -w -r -l -a -v -t /dev/sd'inserted correct value here' –  Russell Clarke Oct 16 '13 at 10:51

2 Answers 2

All OSes have utilities for trying to fix corrupted and/or defective disks. The Linux utility is dosfsck. You should mount the disk with Linux, then run

sudo dosfsck -w -r -l -a -v -t /dev/sdX

where X is the device in question (b? c?...). The -a option takes care of everything automatically.

share|improve this answer

My suspicion is that you've changed the partition type code. Unfortunately, without detailed partitioning information from a tool like Linux's fdisk or gdisk, I can't be sure of this, and I can't provide information on how to fix the problem. I therefore recommend that you boot to Linux and type the following commands (as root or using sudo):

fdisk -l /dev/sdb
gdisk -l /dev/sdb

Edit your original question and post this output. This assumes that the disk in question is /dev/sdb; change that detail if necessary. Note also that many distributions don't install gdisk by default, so you may need to install it (usually in a package called gdisk or gptfdisk) first. Linux needs access to the whole-disk device, too. You mentioned running Linux in a virtual machine, so that may not be the case from your VM. If so, you may need to boot a Linux emergency disc on the "real" computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.