Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a freeBSD server that worked fine in its old location, but I moved it to a new location with a new ISP and a new static IP address. I replaced the old static IP with the new static IP in /etc/rc.conf . I also changed the netmask and defaultrouter to new addresses (given to me by isp). I then changed the nameserver addresses in /etc/resolv.conf

machinename# /etc/rc.d/netif restart

machinename# ping www.google.com

ping: cannot resolve www.google.com: Host name lookup failure.

I have two network cards rl0 and xl0 and after entering

machinename# /etc/rc.d/netif restart

only lo0 and xl0 show up. rl0 is missing.

I have tried two different network topologies

  1. modem --> freeBSD server --> router (topology at previous location)
  2. modem --> router --> freeBSD server (with port forwarding enabled on router)
share|improve this question
    
Can you post the output of ifconfig? It could be a hardware problem. (network card unseated). – Roland Smith Oct 14 '13 at 20:37
    
@Hennes result of ping 8.8.8.8 is "ping: sendto: No route to host" (and you are correct it is rl0 and xl0. that changes things dramatically! ) – shupru Oct 14 '13 at 20:49
    
No route to host. What are thew routing tables? Please add the output from netstat -rn to the post using the edit link. – Hennes Oct 14 '13 at 20:52
    
@RolandSmith I'll have to get a usb stick and copy the output because I don't have connectivity on the freeBSD machine. I'll do that soon. I think the cards are seated because when I change the IPs in rc.conf that change shows up in the output of ifconfig – shupru Oct 14 '13 at 20:55
    
@Hennes My mistake the the changes were made in resolv.conf I'll post soon with the output of ifconfig and netstat -rn – shupru Oct 14 '13 at 20:57
up vote 0 down vote accepted

Solved. My network topology has changed from

modem --> server --> router

to

modem --> router --> server

So I needed to assign a local static IP 192.168.1.3 rather than my external IP.

@Darius provided me with an answer unable to assign external static IP ( /etc/init.d/networking restart hangs )

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .