Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to ssh localhost into the same machine. I copied the generated public key into the authorized_keys file. It still doesn't work. I have spent hours on trying to find a solution to this issue before posting this question. Someone please help me.

[root@155 ~]#ssh -v localhost
OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to localhost [::1] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type 1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'localhost' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:4
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: gssapi-keyex
debug1: No valid Key exchange context
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_0' not found

debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_0' not found

debug1: Unspecified GSS failure.  Minor code may provide more information


debug1: Unspecified GSS failure.  Minor code may provide more information


debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug1: Offering public key: /root/.ssh/id_rsa
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Next authentication method: password
root@localhost's password:
share|improve this question

1 Answer 1

Your private key probably doesn't match the public key on the server side. Please try logging in using a password. If that works, then log in using ssh-copy-id instead of ssh (make sure you have a ssh-agent available and prepare the key with ssh-add). Then try to log in using ssh again. If that works, look at ~/.ssh/authorized_keys again and see what changed.

If that still doesn't work, try ssh -vv to see even more information.

From the current output it looks like public key authentication is enabled both on the server side (otherwise the server wouldn't offer it as an auth mechanism) and on the client side (otherwise the client wouldn't offer the key).

share|improve this answer
    
Thanks for posting. I already tried what you have mentioned. Even that doesn't help. –  Rahul Oct 15 '13 at 23:04
    
Any additional information from ssh -vv? –  Pavel Šimerda Oct 16 '13 at 6:57
    
Also, when you ssh-copy-id, does it add anything to the authorized_keys file? –  Pavel Šimerda Oct 16 '13 at 7:00
    
I had to change the authorized_keys path in sshd_config file. It works absolutely fine now! –  Rahul Oct 17 '13 at 6:49
    
Great. Then I think the usual way is to post it as an answer and accept it yourself to get the question marked answered. –  Pavel Šimerda Oct 17 '13 at 13:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.