Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Im trying to create a symbolic link to a text file with directory:

C:\users\me\textfile.txt

where the shortcut is in the same folder (for simplicity)

using command:

mklink /d "C:\users\me\textfileshortcut.txt" "C:\users\me\textfile.txt"

but this just creates a folder with the name textfileshortcut.txt and not a shortcut to a file.

What am i doing wrong?

Note: I am using windows 7

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You are using the directory /d flag. Remove this flag and you will make links to files rather than directories.

For example,

mklink "C:\users\me\textfileshortcut.txt" "C:\users\me\textfile.txt"

Source: (http://technet.microsoft.com/en-us/library/cc753194.aspx)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.