Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Windows Explorer under XP I see some of my files have green filenames. When I try and copy one of these files I get an error reporting Access denied. The My pictures folder also appears with green text and I have a large number of photos from family holidays I don't want to lose.

I need to backup these files as I'm changing laptop soon.

We use SafeBoot to encrypt our hard drives but I don't think this is the problem as it allows me to copy other files to removable media with no problems.

Has anybody come across this before and how can I resolve this?

Green filename

share|improve this question

2 Answers 2

up vote 13 down vote accepted

Your files are probably encrypted.
Reference: Using File Encryption.

TechNet reference -- Encrypting File System in Windows XP

Because of the unique nature of encrypted files, different results can occur when moving or copying encrypted files between locations. For example, when copying an encrypted file from a local machine to a server on the network, different results of the copy operation will occur depending on the operating system being used on the server. In general, copying a file will inherit the EFS properties of the target, but a move operation will not inherit the EFS properties of the target folder.

The "access denied" error message is returned to applications from the NTFS file system in order to ensure compatibility with existing applications. The use of an alternate or more descriptive error message would cause many applications to fail or behave erratically.

The Windows XP Professional client contains some enhancements in the area of copying encrypted files. Both the shell interface and the command-line now support an option to allow or disallow file decryption. When an encrypted file is copied to a target location that does not allow remote encryption, the user will be prompted with a dialog box that allows a choice of whether or not to decrypt the file.

ArsTechnica discussion: Copying encrypted (Safeboot) hard drive to SSD.

Decrypt the drive, image/copy the partitions, encrypt the new drive.

share|improve this answer
    
Decrypting the drive is not an option but SafeBoot works in the background so I don't think this is the problem. I need to backup the files to a removable drive not use the old HD in a differnt PC. –  Swinders Nov 5 '09 at 12:24
    
Looks like I have somehow enabled the NTFS encryption of certain folders. This is what the green filenames represent. Right click on file/folder and Properties. Then click on 'Advanced...' and uncheck 'Encrypt contents to secure data'. Thanks for the pointers. –  Swinders Nov 5 '09 at 12:27

You have to decrypt the file (right click/properties/advanced/uncheck encrypt) but you are likely to get an access denied error if this file was encrypted on another computer.

If this happens, and you are on Windows 7, and MS have not fixed this since I wrote this response in Dec 2010 (feeling bored), then the only way to decrypt the file is to do it on the very same computer and user that encrypted the file in the first place. If you don't have access to the original computer then start begging MS for a hotfix...

share|improve this answer
2  
Begging for a hotfix will yield nothing. If original computer was not part of a windows domain with Certificate Services properly configured, you cannot recover these files, as autogenerated certificates used to encrypt the files are no longer accessible. –  Denis Nikolaenko Jul 11 '11 at 19:28

protected by Ivo Flipse Jan 7 '11 at 9:35

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.