Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two identical files. stored in two different locations on SharePoint. When I try to download one, I get the options: Open, Save and Cancel. When I try to open the copy in another location, I get the options Save and Cancel.

I am completely dumbfounded as to why my options are different.

This is in IE 10 Windows 8 64bit but the same thing is happening on Windows 7, IE 8/9

The files are emails. I'm using outlook 2013.

The files are stored on SharePoint and right now I have no clue if it's a problem with SharePoint, IE or Outlook.

enter image description here enter image description here

share|improve this question

It has to do with a new-ish "security feature" offering a new field in the header, similar to the issues with PDFs:

In Internet Explorer 8 Microsoft added a security feature to prevent script injection vulnerabilities caused by buggy client software. This feature is activated by a new HTTP header called X-Download-Options which can be set to noopen. When that header is passed with a file attachment Internet Explorer 8 will not provide the option to directly open the file, instead you must first save the file locally and then open it.

and, from

Lastly, for web applications that need to serve untrusted HTML files, we have introduced a mechanism to help prevent the untrusted content from compromising your site’s security. When the new X-Download-Options header is present with the value noopen, the user is prevented from opening a file download directly; instead, they must first save the file locally. When the locally saved file is later opened, it no longer executes in the security context of your site, helping to prevent script injection.

HTTP/1.1 200 OK

Content-Length: 238

Content-Type: text/html

X-Download-Options: noopen

Content-Disposition: attachment; filename=untrustedfile.html

browser protections

share|improve this answer
Hi, thank you for your reply. However, I don't understand why this applies to the same file stored in different locations in a site collection. Is there any way to disable this security feature? It's causing me a lot of problems. – Batman Oct 18 '13 at 4:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .