Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, whenever I try to save a specific document (saving regularly, and even auto-save), Word on mac screws up. If it saves as .docx, it doesn't save the text (maybe it's saving as a template??), and when reopening it, only pictures and art shows up, but no text. If it saves as .doc, when reopening the .doc file, it gives an error message and sometimes crashes the program:

Word was unable to read this document. It
may be corrupt.
Try one or more of the following:
* Open and Repair the file.
* Open the file with the Text Recovery converter.

If I take this .doc file to another (Windows) computer, and open it, it is actually corrupt, but it will open and get the text. But opening the .docx file on the other computer, it's clear there is no text.

I tried resetting Word (resetting the "com.microsoft.office.plist", "com.microsoft.word.plist", and "Normal.dotm" files), but it didn't help.

p.s. Saving as PDF seems to work fine.

Could this be some kind of issue with saving modules? And if so, how would I reset/reinstall/replace them?

Update: So, it will save other documents, but the document I'm saving was 36 MB from pictures. I compressed the pictures down, and it will save as .doc file and open without the error, but now the .doc file no longer has text.

share|improve this question
1  
When you say "opening the .docx file on the other computer, it's clear there is no text" do you mean "opening in Word on the Windows computer" or do you mean that you have looked inside the .docx (e.g. append .zip to the name on Windows then look inside) and found that the text is missing from the /word/document.xml file ? If you haven't tried the latter, it may be worth checking - I am wondering whether there is a problem with the XML, although normally Word flags an error in that case. –  bibadia Oct 18 '13 at 10:37
    
Sorry. Actually I tried both - I unzipped it right on the Mac, though - I didn't thoroughly search for it, but from what I did look through, it wasn't there. I'll definitely give the document.xml a look though. –  AUTO Oct 20 '13 at 0:33
    
Unfortunately, I don't have any more ideas on this one. Looking around, it seems that having track changes switched on and large file size can have an impact. There is also a feature that adds a lot of XML code in Windows Word (lots of <w:rsid> elements) that can be switched off in Windows, but OTTOMH I don't know how to switch it off on Mac. For troubleshooting, the usual advice is (a) try with a newly created login. If you really have to do uninstall, there is an article at support.microsoft.com/kb/2398768 . –  bibadia Oct 20 '13 at 17:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.