Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Java on my webserver (Unbuntu - Parallels Plesk). I logged in to the server with PuTTY and tried some commands like:

sudo apt-get install openjdk-6-jre

or

sudo apt-get install oracle-java7-installer

But than I get error's like:

Package drweb-bases must be reinstalled, but there can be no archive found.

What you I need to do? I am doing it completly wrong? Am I not destroying my webserver? There is not much to find on this topic on Google.

share|improve this question

migrated from stackoverflow.com Oct 17 '13 at 16:51

This question came from our site for professional and enthusiast programmers.

2  
try ask this at askubuntu.com – Michael Wiles Oct 17 '13 at 14:31
    
Thanks, I will post it there. – atMaarten Oct 17 '13 at 15:13

I normally use this PPA to install Oracle's Java.

http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html

But in you case have tried sudo apt-get update, first? Maybe your package list outdated?

share|improve this answer
    
I tried update and it did some updates, but still not able to install java. I also tried the webupd8 methode and got this: sudo: add-apt-repository: command not found – atMaarten Oct 17 '13 at 14:44
    
@atMaarten Install software-properties-common to fix that error. Just doing: sudo apt-get install software-proprieties-common – Achu Oct 17 '13 at 15:21
    
@Achu I tried and it started, but when it was done, some error (Package drweb-bases must be reinstalled, but there can be no archive found.) – atMaarten Oct 17 '13 at 15:31

The package is related to Dr.Web Antivirus for Linux. You can try updating or reinstalling it following this documentation

Debian, Ubuntu (apt) 1. Installation: Debian repository is signed by the digital key. For correct operation you need to import the key with command

wget -O - http://officeshield.drweb.com/drweb/drweb.key | apt-key add

or

curl http://officeshield.drweb.com/drweb/drweb.key | apt-key add -

To add the repository to you system, add the following line to /etc/apt/sources.list file: deb http://officeshield.drweb.com/drweb/debian stable non-free

To install Dr.Web Anti-Virus for Linux issue commands:

apt-get update
apt-get install drweb-cc

2. Deinstallation: To remove Dr.Web Anti-Virus for Linux issue command:

apt-get remove drweb-cc

To remove all installed packages from Dr.Web, issue command (may be before '*' you'll need to use backslash: '*'):

apt-get remove drweb*

To automatic removing from a system not used packages you can issue command:

apt-get autoremove

After completing all the steps above, try installing Java

share|improve this answer
    
Thanks for the tips! I succesfully executed the curl command, but when I try to install or remove the Dr.Web I still get that some error. (Package drweb-bases must be reinstalled, but there can be no archive found.) – atMaarten Oct 17 '13 at 15:15
    
check this link - kb.parallels.com/en/113611 – Keerthi Ramanathan Oct 17 '13 at 15:43
    
I also found this website. I tried the command and got no feedback form the terminal, so that's good? I plesk I says: drweb - The component was not installed. When I try to install Java, I still got the same error (E: Package drweb-bases must be reinstalled, but there can be no archive found.) – atMaarten Oct 17 '13 at 15:52
    
apt-get-autoremove --purge packagename to remove config files as well – Keerthi Ramanathan Oct 17 '13 at 16:07
    
That would be in my case: #apt-get-autoremove --purge drweb* Run the command, still the same error when installing Java. – atMaarten Oct 17 '13 at 17:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .