Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a document library, where one of the columns does not show up in the edit and new form.

How do I get back in the forms, so that the users can edit (and create) items including this column/field.

The field is perfectly visible in "datasheet" mode where you can edit too but I would love to have the forms back in order :o)

share|improve this question
    
I already tried to add/remove managing content types, but it did nok fix the problem with the form. –  noesgard Dec 9 '09 at 12:39

2 Answers 2

Just had this same problem with SharePoint 2007 and posting my solution for anyone else that might come across it.

We have a Document Library with 31 metadata items - yes 31! Have been using this library for months with lots of documents all with metadata populated. Suddenly all the fields, except for Title, disappeared from the Edit Properties form. Luckily the metaddata wasn't lost as you could still see the metadata in the Document Library views, but couldn't edit them as they didn't appear in the Edit Properties form. For Word documents, open in Word 2010, showing the document properties panel only shows Title. BUT, now all metadata field show as Custom properties (as viewable in Advanced Properties dialog).

Upon investigating I found that SOMEONE had created a Content Type of "Document" for this library - which we didn't have before this problem- AND only the Title field listed as properties. I couldn't delete this Content Type getting a message "document already exists" so decided to make the Content Type fit my needs. Here's how I did it.

In Library Settings > Advance Settings > "Allow management of Content Types" set back to "Yes". Then, in Library Settings, under Content Types clicked "Document" to open the settings for the content type. Click on "Add from existing site or list columns". In the Content Type settings form, the "Select columns from:" dropdown list is defaulted to List Columns (which listed all the Document Library metadata fields that I was missing). Selected and added them all. Then went to change column order for the Content Type as they were before.

They now appear in the Edit Properties form (and Word Document Information Panel) as desired.

Hope that helps someone because it wasted a day of my time.

share|improve this answer

In your Document Library Settings there is a "Content Types" section which controls the properties that are displayed for editing in your library. If this section is not visible to you then you must open your "Advanced Settings" link under General Settings and set "Allow management of content types" to "yes" at the top of that page. Once visible, click on the content type you are concerned with (e.g., document) and you will then be presented with the option to "Add from existing site or list columns". The interface to include the desired columns is a simple process of selecting and moving the column names from the left window to the right window.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.