Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Windows XP SP3 and IE 7.0.5730.13 I need to be able to debug javascript viewing my Website in IE7 I've gone into Internet Options > Advanced and unchecked 'Disable Script Debugging' boxes. I've installed MS Visual Web Developer 2010 Express. After installing MSVWD I get the IE View-menu option 'Script Debugger' But when I select Script Debugger > Open, nothing happens. It fails silently to do anything. When I go to a page that I know has JS errors, I get no notification.

Can someone please let me know what to try next, to get Script Errors to appear?

share|improve this question
Just want to make sure -- you have to restart IE when changing this setting. – Debra Oct 17 '13 at 22:36
yes, in fact have restarted the PC several times – George Oct 17 '13 at 23:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.