Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded from Windows 8 to Windows 8.1. I have an Alienware Aurora R4 with the latest BIOS firmware version, A09. Ever since I did the upgrade, I get a watermark on my desktop saying, "SecureBoot isn't configured correctly"...I would like to get rid of this watermark the correct way (not by hacking system DLLs). My BIOS shows me booting in UEFI mode, and I see that SecureBoot is actually disabled from there. I cannot enable SecureBoot, in either UEFI mode or Legacy Boot mode. Note, I can't even get Legacy Boot mode working without re-formatting my system which I really don't plan on doing, so my question is this...what has changed in the way Windows handles SecureBoot? As far as I can tell, I do not have SecureBoot enabled, and it is trying to tell me that it isn't configured correctly. Why does it even care to check if my BIOS doesn't have it on anyways?! Its so frustrating!

share|improve this question
1  
Lets start with what sort of partition you have MBR or GPT? –  Ramhound Oct 17 '13 at 23:10
    
Disk 0 is GPT. Disk 1 is also GPT. –  Alexandru Oct 18 '13 at 0:59
    
Got the same problem :/ –  Philipp M Oct 19 '13 at 13:45
add comment

2 Answers

I asked this Microsoft and the answer was, that they show this watermark to make sure that OEMs don't release new systems without having SecureBoot turned on.

share|improve this answer
    
This doesn't make sense for me, since I have an "old" system by their definition, and its already disabled in the BIOS with no way to enable it. I'm shaking my head right now. This is completely unacceptable. Microsoft...how can you mess up on a Windows release this bad? –  Alexandru Oct 18 '13 at 12:21
    
I'm also confused by this answer. I'll stay at Win8, here I'm not annoyed by this watermark. –  magicandre1981 Oct 18 '13 at 17:12
add comment

I have also this problem. And i have fixed the problem You can find your answer on this link: Windows 8 to 8.1 Pro Upgrade SecureBoot Error

share|improve this answer
    
This does not work for me. I cannot enable SecureBoot in my BIOS like you can. –  Alexandru Oct 21 '13 at 19:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.