Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After installing windows 8.1 update, lot of applications like Chrome, Skype etc looks blurry. How to fix it?

E.g: (bigger image here). Blurry windows

share|improve this question

3 Answers 3

up vote 39 down vote accepted

Fix: You should disable scaling by opening properties of the application/short cut.

disable scaling

update: Even better to disable the DPI scaling by custom sizing option

enter image description here

share|improve this answer
2  
Disabling DPI scaling (the second option) worked perfectly for me. Thank you so much, was driving me crazy!! –  AJ. Oct 21 '13 at 13:05
    
Thanks! You saved me from getting crazy! –  Marc-Andre R. Nov 29 '13 at 4:42

The blurry text is caused by the new DPI scaling which is added in 8.1.

Set the size back to 100% and this fixes the issue.

enter image description here

share|improve this answer
2  
Setting the size back to 100% strains my eyes thats the reason why i changed the size in the first place, I have found the solution thats disabling auto DPI scalling, look at my updated answer! –  Dhana Oct 19 '13 at 18:26
    
ok, thanks. For me 100% is fine. –  magicandre1981 Oct 20 '13 at 5:46
3  
This is not new in Windows 8.1 -- display scaling has been with us since at least Vista. And a Surface and similar device really needs scaling, which worked just fine on 8.0. I think there must be more to this story, because 125% scaling in 8.0 was fine (and necessary); 8.1 is all fuzzy. –  Jon Watte Nov 22 '13 at 16:57
    
in 8.1 the scaling was changed to make it independent for each monitor. Vista till 8.0 the setting was applied for all monitors. –  magicandre1981 Nov 22 '13 at 18:00
    
DPI scaling is a piece of shit. It resets my mouse sensitivity when I go fullscreen (e.g. when I launch a game)... I have to change manually all the time. Makes me really nervous.. –  Nickon Dec 24 '13 at 16:55

If you want to make it easier to disable DPI scaling you can add a "Disable DPI scaling" right-click context menu option to .exe files by saving the following code to a .reg file and double clicking it to import into the registry:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\disabledpi]
@="Disable DP&I Scaling"

[HKEY_CLASSES_ROOT\exefile\shell\disabledpi\command]
@="cmd /c @reg add \"HKCU\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers\" /v \"%1\" /f /t REG_SZ /d \"~ HIGHDPIAWARE\">nul"
"IsolatedCommand"="cmd /c @reg add \"HKCU\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers\" /v \"%1\" /f /t REG_SZ /d \"~ HIGHDPIAWARE\">nul"

This also works on files for which the Compatibility tab is missing like mmc.exe and all its windows, i.e. Services, Group Policy Editor, etc. all clear up when the DPI awareness flag is set for mmc.exe.

I can't include images so here's a link to what the result looks like on my machine: Right-click menu screenshot

A more complete solution if you want to include MSI files (which are also all missing the tab) and the option to right click a folder to add its EXE and MSI files to the registry key, this REG import should take care of it:

Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\exefile\shell\disabledpi]

[HKEY_CLASSES_ROOT\exefile\shell\disabledpi]
@="Disable DP&I Scaling"

[HKEY_CLASSES_ROOT\exefile\shell\disabledpi\command]
@="cmd /c @reg add \"HKCU\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers\" /v \"%1\" /f /t REG_SZ /d \"~ HIGHDPIAWARE\">nul"
"IsolatedCommand"="cmd /c @reg add \"HKCU\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers\" /v \"%1\" /f /t REG_SZ /d \"~ HIGHDPIAWARE\">nul"

[-HKEY_CLASSES_ROOT\Msi.Package\shell\disabledpi]

[HKEY_CLASSES_ROOT\Msi.Package\shell\disabledpi]
@="Disable DP&I Scaling"

[HKEY_CLASSES_ROOT\Msi.Package\shell\disabledpi\command]
@="cmd /c @reg add \"HKCU\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers\" /v \"%1\" /f /t REG_SZ /d \"~ HIGHDPIAWARE\">nul"
"IsolatedCommand"="cmd /c @reg add \"HKCU\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers\" /v \"%1\" /f /t REG_SZ /d \"~ HIGHDPIAWARE\">nul"

[-HKEY_CLASSES_ROOT\Directory\shell\disabledpi]

[HKEY_CLASSES_ROOT\Directory\shell\disabledpi]
@="Disable DP&I Scaling"

[HKEY_CLASSES_ROOT\Directory\shell\disabledpi\command]
@="cmd /c @start /min cmd /c for /f \"usebackq delims=\" %%i in (`dir /b /s \"%1\\*.exe\" \"%1\\*.msi\"`) do @reg add \"HKCU\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers\" /v \"%%i\" /f /t REG_SZ /d \"~ HIGHDPIAWARE\""
"IsolatedCommand"="cmd /c @start /min cmd /c for /f \"usebackq delims=\" %%i in (`dir /b /s \"%1\\*.exe\" \"%1\\*.msi\"`) do @reg add \"HKCU\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers\" /v \"%%i\" /f /t REG_SZ /d \"~ HIGHDPIAWARE\""

This comes with a few gotchas like a reminder not to use the folder option on a root-level folder so there aren't hundreds of registry entries created at once. There's a bit more detail in an answer I posted at Server Fault where third-party utilities and other approaches are also covered:

How can I make Microsoft Management Console high-DPI aware in Windows 8.1?

Everything you should need is in the code snippet above though.

It's all still a work in progress, and I'm sure it will be resolved eventually, but hacks like this are needed in the meantime. A good example of a use case is the question above, since the manifest for the Microsoft Management Console doesn't set high DPI awarenesss, and the option to enable it is not available due to a Windows policy that makes the Compatibility tab not show up in the Properties panel for system files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.