Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 Pro and am try to backup 116 GB of data to my external 1 TB hard drive. My laptop has only USB 2.0 ports and my hard drive is USB 3.0 compatible, as is the cable I'm using. I understand that the transfer speed should still be in accordance with USB 2.0 speeds. However, right now I'm getting 135 KB/s and it's been gradually dropping. For an earlier transfer, I would get between 4 MB/s to 8 MB/s. So, I'm really just wondering what's going on with my transfer rate and what I can do to improve it. I'm currently about 35 GB into the 116 GB transfer.

Another strange thing is that the window which shows the transfer status decided to max out at 835 MB, and therefore shows items remaining as 0. However, it is still performing the rest of the transfer, and I can see it still cycling through files.

Now that I think about it, it seems plausible that the speed being shown by the window is calculated merely as total data transferred / time elapsed. Since the "counter" of data, as far as what is being displayed in the window, maxed out at 835 MB, as time increases, the speed shown is going to keep decreasing because the 'total data transferred' value isn't being incremented.

So with that in mind, I suppose I don't actually know at what rate the data is being transferred currently. Nonetheless, my best speed earlier was only around 8 MB/s. Shouldn't USB 2.0 deliver closer to 35 MB/s? Also, if someone can tell me why the transfer status window is displaying the incorrect data information and how to fix this, that would also be appreciated.

share|improve this question
    
Are you noticing high CPU or disk usage? Have you tried other programs or commands for copying? –  golimar Oct 18 '13 at 11:44
    
Neither high CPU nor disk usage. And I've just been straight up copy + pasting from my C: drive to my external drive. –  Wolfram Oct 18 '13 at 22:48
    
Is it a big file or many smaller ones? Try the copy command or the Teracopy program –  golimar Oct 19 '13 at 8:44
    
Both. I'm doing a Pre-Windows 8.1 update backup. I think I got the speed stuff sorted out. The only issue is that sometimes the status window will show the status only for, say, the first 832 MB of data. After that, I have no idea how much is left to transfer or how long it's going to take. I end up having to just wait for it to finish. Sometimes though, it only transfers, say, 32 GB/116 GB... so it makes this very difficult. –  Wolfram Oct 19 '13 at 22:27

1 Answer 1

If you use a tower PC and if you are using a front USB port integrated into your case: Try a rear USB port (mounted on the mainboard) and check if something changes.

Did you try another cable? Another port? Another PC?

share|improve this answer
    
I'm using a laptop. –  Wolfram Oct 18 '13 at 9:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.