Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I find that wake on lan stop working after my Mac Mini (late 2012 model, running OS X 10.8.5) has entered safe sleep (which is 4 hours after sleep starts). Because I often travel and want to remote into my machine, and because I'd rather not disable sleep completely, and because I haven't found any way to wake the machine remotely after it has entered safe sleep, my only option remains to disable it. After reading through this discussion, I have set up my power options thusly:

Active Profiles:
AC Power                -1*
Currently in use:
 standby              0
 powerbutton          1
 womp                 1
 autorestart          1
 hibernatefile        /var/vm/sleepimage
 networkoversleep     0
 disksleep            0
 sleep                30 (sleep prevented by )
 autopoweroffdelay    14400
 hibernatemode        0
 autopoweroff         0
 ttyskeepawake        1
 displaysleep         10
 standbydelay         4200

Notice that autopoweroff is set to 0. Despite this, the computer still enters safe sleep and thus wake on lan stops working after a period of time (4 hours, which I believe comes from autopoweroffdelay of 14400 seconds).

Any ideas on why this is still happening, or what I can possibly do to rectify it?

Update: a related question is, what magic does the built-in VNC client (i.e. when you open safari and go to vnc://whatever/) do to wake the remote host up? Apparently whatever it does appears to work with my configuration even though the magic packet sent through the router doesn't.

share|improve this question
    
Have you tried resetting the pram and is the firwmare up to date? (I just did a search on this issue and seems like other Mac Minis have the same problem) –  Hefewe1zen Oct 18 '13 at 14:57
    
Haven't tried resetting PRAM, I'll give that a shot. Firmware is latest as of now (MM61.0106.B03). –  jeff303 Oct 18 '13 at 15:27
    
I upgraded to Mavericks (10.9), and then later reset the PRAM, testing after each step. Neither one fixed the problem. I guess I'll just try bumping up autopoweroffdelay to some absurdly huge number to delay it as long as possible. –  jeff303 Oct 28 '13 at 12:13
add comment

1 Answer

Safe sleep usually refers to hibernation mode, or to the hybrid sleep / hibernation mode that laptops use by default. In http://support.apple.com/kb/HT1757, "safe sleep" is used a bit ambiguously, but it seems to refer to the hibernation-only mode that a Mac can enter if standby mode or the autopoweroff feature is enabled.

If you mean standby mode or autopoweroff, they should probably be disabled by sudo pmset -a standby 0 autopoweroff 0. Since in your case they are not, you could also try running something like sudo pmset -a autopoweroffdelay 99999999.

Relevant parts of the pmset man page:

hibernatemode takes a bitfield argument defining SafeSleep behavior.
Passing 0 disables SafeSleep altogether, forcing the computer into a reg-
ular sleep.

[...]

hibernatemode = 0 (binary 0000) by default on supported desktops. The
system will not back memory up to persistent storage. The system must
wake from the contents of memory; the system will lose context on power
loss. This is, historically, plain old sleep.

hibernatemode = 3 (binary 0011) by default on supported portables. The
system will store a copy of memory to persistent storage (the disk), and
will power memory during sleep. The system will wake from memory, unless
a power loss forces it to restore from disk image.

hibernatemode = 25 (binary 0001 1001) is only settable via pmset. The
system will store a copy of memory to persistent storage (the disk), and
will remove power to memory. The system will restore from disk image. If
you want "hibernation" - slower sleeps, slower wakes, and better battery
life, you should use this setting.

[...]

standby causes kernel power management to automatically hibernate a
machine after it has slept for a specified time period. This saves power
while asleep. This setting defaults to ON for supported hardware. The
setting standby will be visible in pmset -g if the feature is supported
on this machine.

standby only works if hibernation is turned on to hibernatemode 3 or 25.

standbydelay specifies the delay, in seconds, before writing the hiberna-
tion image to disk and powering off memory for Standby.

There might also be some bugs in the implementation of the autopoweroff feature in 10.8, or the answer to this question might be to upgrade to 10.9.

share|improve this answer
    
Thanks for the answer and relevant snippet from manpage. Unfortunately, upgrading to 10.9 did not fix the problem. –  jeff303 Oct 28 '13 at 12:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.