Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I own a Thinkpad X121e and I upgraded its Ubuntu from 13.04 64bit to 13.10 64bit using the Update Manager. When the upgrade process suggested to restart the system, I restarted the computer and now it says "Operating system not found" after a very brief splash screen.

The splash screen says something like (too brief to see everything):

Intel UNDI, PXE-2.0 ...
For Atheros ethernet Controller ...

Check cable connection!
PXE-MOF: Exiting INTEL PXE ROM

I prepared a startup USB disk using Ubuntu 13.10. I tried the startup USB and it works very well on other computers. So I changed the booting order of X121e and tried all three USB slots, all said "Operating System not found" without any splash screen.

I also tried using startup USB with 12.04 LTS. Same results.

I do not really want to reinstall the system now. Any hints on how to proceed?

ps. I have tested the memory and hard drive using Lenovo software and both passed the test.

Problem solved: 1. It turned out the USB was formatted in NTFS by default on a windows machine. Changing it to FAT32 makes the laptop recognizes it; 2. After booting from the USB, I installed and ran boot-repair and the system is fixed.

share|improve this question
    
Can you confirm the disk is found in BIOS at all? –  xstnc Oct 18 '13 at 21:00
    
Hi, xstnc, the USB is found because in the Boot Menu I can see the usb disk. –  Hongbo Zhu Oct 18 '13 at 21:23
    
The messages you posted above are your system trying different boot devices (PXE is a network boot protocol). –  Oliver Salzburg Oct 18 '13 at 22:17
    
Yes. But when I changed the boot order and used the USB stick, the splash screen with the PXE messages are gone. –  Hongbo Zhu Oct 18 '13 at 22:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.