Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have upgraded my Windows 8 PC to 8.1 yesterday and it seemed like everything is working fine until I tried to create System Image. I got an error 0x80780119 saying that there is to little space on one of the partitions.

I started looking into this problem and indeed one of the partitions does not meet the requirements. There are following partitions on my drive:

DISKPART> list partition


  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
  Partition 1    Recovery           300 MB  1024 KB
  Partition 2    System             100 MB   301 MB
  Partition 3    Reserved           128 MB   401 MB
  Partition 4    Primary             74 GB   529 MB
  Partition 5    Primary            390 GB    75 GB

Partition 1 has only 13MB free space. Partition 2 has 70MB free space, partition 3 is MSFTRES, partition 4 is my C drive with around 35GB free and partition 5 is not included in system image. Partitions were create like this during installation of Windows 8 - clean install from scratch. I am using UEFI so the drive is GPT formatted.

So I thought, OK I can resize my C drive a little, move the partitions and expand the 1st one. I tried using GParted but it is not able to move the MSFTRES partition. It does not recognize the file system on it.

So the question is:

Is it possible to "clean up" the 1st partition in anyway? If not, is there anything special about MSFTRES partition? Or can I just remove it and create it a little further and just flag it as msftres with GParted?

share|improve this question

1 Answer 1

up vote 0 down vote accepted
  • This applies only to UEFI and GPT installations! *

OK it took me a while to figure out what to do, but I have managed to fix that.

First of all create backup of everything you have on your PC that is valueable. In my case I created only the system image using Macrium Reflect Free.

Secondly I have installed EaseUS Partition Master Free and shrinked the system partition (C:). Then I have copied the 128MB MSFT partition closer to the C partition and removed the original one. For some reason the EaseUS Partition Master did not want to copy the EFI partition so I used MiniTool Partition Manager (also free) to copy it just like the 128MB partition. Last I had to expand the Recovery Partition.

After restart I turned out that recovery partition is broken for some reason and Windows does not recognize it. So I booted with GParted live CD to check if it is OK and it was - so no luck here. But I have noticed that the 128MB one does not have proper flag set, so I set it to MSFTRES with GParted.

OK. The only thing left to fix was the recovery partition. I decided to format it and deploy the Windows Recovery Environment again. So I removed the partition just to be sure that I get clean "normal" partition and created it again using EaseUS. Then I have followed this tutorial: http://www.sepago.de/e/nicholas/2012/07/25/windows-recovery-environment-re-explained . I just had to set proper flags on the volume with DISKPART: gpt attributes=0x8000000000000001.

After reboot and some quick testing I saw that everything works fine, but for some reason the recovery partition is mounted on every boot even though it is hidden. Disk Management showed that the partition should not have any letter assigned, but it was visible in "This PC". I removed the letter using Diskpart and then immediately fixed the MountedDevices registry key using this little tool: http://www.techspot.com/community/topics/usb-drive-or-flash-problems-how-to-cleanup-and-remove-old-usb-storage-drivers.145884/ .

Now everything is up and running. Windows sees the recovery environment and backup works as charm.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.