Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Earlier today I installed Windows 8.1, and when I wanted to go into Catalyst Control Center, I noticed some odd error of CCC not being able to display options. I then figured I needed a driver update, so I downloaded the latest drivers, version 13.9, and tried to install them.

While it was trying to install the display drivers, I got a blue screen. Tried again and got the same. Then I used an uninstall tool from AMD to remove all traces of my old drivers and tried to install the new drivers. Again, a blue screen.

This is all I could think of to try. Would anyone know some other things I can try?

EDIT: thought I might want to include the log entry for the crash:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Microsoft-Windows-WER-SystemErrorReporting" Guid="{ABCE23E7-DE45-4366-8631-84FA6C525952}" EventSourceName="BugCheck" /> 
  <EventID Qualifiers="16384">1001</EventID> 
  <Version>0</Version> 
  <Level>2</Level> 
  <Task>0</Task> 
  <Opcode>0</Opcode> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2013-10-19T20:59:25.000000000Z" /> 
  <EventRecordID>26587</EventRecordID> 
  <Correlation /> 
  <Execution ProcessID="0" ThreadID="0" /> 
  <Channel>System</Channel> 
  <Computer>Simon-PC</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data Name="param1">0x0000007e (0xffffffffc0000005, 0xfffff80002a86dca, 0xffffd00025f250e8, 0xffffd00025f248f0)</Data> 
  <Data Name="param2">C:\WINDOWS\MEMORY.DMP</Data> 
  <Data Name="param3">101913-8953-01</Data> 
  </EventData>
  </Event>

Another edit:

As it turns out, the graphics card isn't showing up any more in the device manager. But as far as I can tell, it is still working (the fans are spinning and my screen is plugged into that graphics card).

This is solved. it appears that my graphics card is now running with a default windows driver.

I also tried the forced method mentioned here: AMD Graphics Drivers won't install properly . But I still get a BSOD.

Third edit: Slight succes! Managed to install version 13.4. Everything appears to be working fine now. I think I'm just going to skip version 13.9.

share|improve this question
    
I have the same problem. I can't install 13.9 on my system. The display driver always fails. AMD used to have good drivers, now they're just pumping out trash. –  Alexandru Dec 14 '13 at 16:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.