Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using OpenNX on a Mac to connect to a NoMachine 3.5 server on Ubuntu, and I was able to start a new GNOME session with the using the available screen area.

However, this behavior changed recently (with an update, I think). Now whenever I connect the NX session is forced to the native 1920x1200 resolution of the monitor attached to the server, rather than the client screen area. I tried manually setting the resolution to 800x600 in OpenNX but this too got forced to 1920x1200. In both cases OpenNX briefly displays a window of the desired size, before resizing to take up my whole Mac desktop with the even bigger 1920x1200 GNOME session underneath.

I tried to repeat this test using the NoMachine client on a Windows 7 machine and I got similar results.

Has anyone experienced this issue? I found a couple of workarounds, but nothing to indicate why my NX session blows up to 1920x1200 in the first place.

Workaround 1

Once in the NX session, I am able to hit Ctrl-Alt-R once or twice (depending on which mode the session is started in) to switch to auto-resize mode and force the NX session back to the size of the client window.

Workaround 2

I can change the monitor resolution from within Ubuntu's System Preferences in the NX session. But then if I log out and log back in again, I get errors as GNOME tries to re-apply the monitor settings.

Setup

  • Ubuntu 12.04 64-bit (NoMachine server)
    nxserver-3.5.0-11
    nxclient-3.5.0-11
    nxnode-3.5.0-11

  • Mac OSX 10.8.5 (NoMachine client)
    OpenNX-0.16.0.725

  • Windows 7 Enterprise (NoMachine client)
    nxclient-3.5.0-9

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.