Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to upgrade from Windows 8 to Windows 8.1. Unfortunately, during the upgrade process I receive the following error:

Sorry, it looks like this PC can't run Windows 8.1. This might be because the Users or Program Files folder is being redirected to another partition.

Which is accurate in that I have my Users directory on my D: drive and Windows installed on my C: drive. I do this because my C: drive is an SSD drive and D: drive is a spinning rust drive where I keep my data. Is it possible to upgrade to Windows 8.1 from a Windows 8 install with a redirected Users folder?

I do not consider a full reinstall of Windows 8 with a non-mapped Users folder and then upgrading that installation to be "upgrading."

share|improve this question
    
It is not possible. Here is an article about this: zdnet.com/… –  Thijs Oct 20 '13 at 14:01
    
@Thijs thank you for the link. For some reason that did not appear in my Googling last night. Since this configuration worked with my Windows 7 installation for all the years I used that OS I decided to use it again when installing Windows 8. Unless something changes I see a system repave in my future. Thank you for the link. –  ahsteele Oct 20 '13 at 16:24
    
Why don't you move your users directory back to C: then upgrade and finally move it back to D: –  Peter Hahndorf Oct 20 '13 at 19:28
2  
@PeterHahndorf I didn't think the Users folder could be moved without all sort of heartache. –  ahsteele Oct 20 '13 at 20:51
    
I had the same problem. An other fun thing about it, you're not able to download apps from the Windows Store when the users directory is on an other partition/drive –  Thijs Oct 21 '13 at 13:30
add comment

2 Answers

HUNeutrino had a sort-of solution.

The steps I made for the successful upgrade: (I am not sure if all these are required but this worked for me)

  • I reset HKLM/SOFTWARE/Microsoft/Windows NT/CurrentVersion/ProfileList/ProfilesDirectory back to "%SystemDrive%\Users".
  • I created a new account (after the first step it will be created in C:\Users )
  • I made the new account Administrator (Control panel, change user type)
  • I signed out with my existing user
  • I signed in with the newly created user
  • I opened an administrator command prompt and made a Junction from the C: profile folders to the D: profile folders running mklink /J C:\Users\Username D:\Users\Username
  • I changed the HKLM/SOFTWARE/Microsoft/Windows NT/CurrentVersion/ProfileList/S-1-5-xx-xxxxxxxx-xxxxxxxxxxxxxx/ProfileImagePath keys that point to D:\Users\Username to C:\Users\Username
  • Verified that I could still log in to desktop with the user.
  • (I guess the previous 3 steps should be repeated for all the accounts with profile folders on D)
  • Installed all pending updates and made a full restart to make sure that the no user on D is logged in
  • Downloaded and installed the 8.1 update successfully :-) .
share|improve this answer
    
Hello and welcome to superuser.com. Please rewrite your answer to include the solution itself. If the site you are referring to would change for some reason or the site itself goes down, the solution would no longer be accessible. Writing it in the answer makes sure that the solution is there no matter what happens. –  Mogget Nov 10 '13 at 9:47
    
Got a description now. –  Roger Willcocks Dec 3 '13 at 9:28
add comment

I used sysprep to move my user folders following this tutorial I just sucesfully upgraded to 8.1 following the direction I found here

  1. Create a local account (yes do this before you change anything in regedit. I ran into User Profile service problems if I created users after the fact). Give this account Local Admin by adding to the Administrators group. Make sure you can log into this account.
  2. Boot into Safe mode easiest way is to use msconfig
  3. Log in with the new local admin and copy all other accounts to the normal spot on the c drive.
  4. Log out and log into your normal user (presumably admin priveleges) and copy the temp admin user to the c drive.
  5. Now modify the registry. You must do both option 1 and 2. Follow the guide Here to change (using regedit) the default locations of the user profiles to*%SystemDrive%\Users*.
  6. Exit Safe mode
  7. Log into your normal account or the temp admin. I used temp admin
  8. Goto windows store and start the win 8.1 install. Once you get past verifying then it should complete.
  9. After it installs you be asked to log in I used the tempo admin account. You should see the metro apps update.
  10. I also logged in to my normal account to make sure it updated.
  11. Go back to safe mode
  12. Log in with the temp admin account.
  13. Copy all the user directories to the original spot you had them. I assume Microsoft installed or updated stuff there.
  14. Sign out and sign in with your normal user and copy the Temp admin's user directory back to the orginal spot
  15. Use regedit again to revert back your changes. Found in step 5
  16. Exit safe more
  17. Enter normal boot mode and log in with your normal user.
  18. You can now move or delete the user accounts you had to copy. I backed mine up to the data drive. The update installs some extra users I think to the c:\users so don't mess with those.

Here is a summary of the directions on changing the registry files linked to in the quote above.

Using Regedit navigate to the following location

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

enter image description here

In the left pane under the Profilelist key, select and look at each S-1-5 key with the long number until you see the user account name and path (step 3) that you want to move in the value Data column of ProfileImagePath in the right pane. When the correct user name is found, right click on ProfileImagePath, and click on Modify. (see screenshot above)

Type in the full path of the location (ex: E:\User account to move) that you copied the user profile folder to in step 7, and click on OK.

Also change the default location back to the default using Regedit to navigate to the following

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

enter image description here

In the right pane of ProfileList, right click on ProfilesDirectory and click on Modify. (see screenshot above)

type %SystemDrive%\Users

Once you completed the upgrade you can move everything back.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.