Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After updating my windows 8 to windows 8.1 I received an error on startup.

It says: There was a problem starting C:\Windows\System32\LogiLDA.dll The specified module could not be found.

What is the problem? Or how can I fix this?

I have an Asus Ultrabook UX31A.

share|improve this question

migrated from stackoverflow.com Oct 20 '13 at 11:22

This question came from our site for professional and enthusiast programmers.

1  
I'm getting this too on a Surface Pro. From the google searches I've done it seems to be part of logitech download assistant. I have used a logitech mouse with my Surface Pro but I've never installed any of the logitech software so I don't know why it's requesting that file. –  OFB Oct 17 '13 at 15:15
    
This DOES come with windows 8.1 update. I don't have any Logitech devices on my HP laptop and still got this annoying message after updating windows 8 to 8.1. –  vasko Oct 18 '13 at 14:50

6 Answers 6

  • Run Task manager by pressing CtrlAltDel
  • Go to Startup tab
  • Find LogiLDA, right click on it and click Disable

After a restart, the problem is gone.

share|improve this answer
2  
MUCH better than changing the Registry. –  Joshua Oct 22 '13 at 22:07
    
I agree. No need to run around willy nilly dropping registry entries, even for Logitech devices that could very well be fine otherwise. Also, this worked for me, too. Was a product of the Windows 8.1 upgrade. –  dudewad Nov 14 '13 at 1:56
up vote 13 down vote accepted

Ok, from what I've seen you can just remove the registry entry for the dll. I tried it already and nothing seems to be messed up with the file missing. It's almost as if someone at MS had LDA installed and didn't bother to clean up the registry before publishing the update.

You can paste this into a batch file and run it as administrator or just open an administrator command prompt and paste it into there to quickly get rid of the entry.

echo Start 
echo # 
echo ######################## Default dirctory for x86 x64 ######################## 
echo # 
echo this command is default system32 directory for x86 OS or x64 OS 
cd %windir% & cd system32 
reg delete "HKCU\Software\Microsoft\Windows\CurrentVersion\Run" /v "Logitech Download Assistant" /f 
reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /v "Logitech Download Assistant" /f 
echo # 
echo ######################## Change the dirctory for x64 ######################## 
echo # 
echo this command is x86 application's registry for x64 OS 
cd %windir% & cd syswow64 
reg delete "HKCU\Software\Microsoft\Windows\CurrentVersion\Run" /v "Logitech Download Assistant" /f 
reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /v "Logitech Download Assistant" /f 
echo End

I found the code above here.

share|improve this answer
1  
The registry key did not come from the 8.1 update. More likely, you've used a Logitech mouse (or wireless dongle) in the past which installed the download assist. –  dlux Oct 17 '13 at 21:31
    
That's true, but it's definitely connected to the 8.1 update (because it happened to me too). Presumably the update wiped out the directory holding the dll. –  advs89 Oct 29 '13 at 23:09

I just called Logitech corporate office and they helped me disable the file without uninstalling it which could disable other files on the computer. Here is what he told me to do. It's a simple fix.

Go to either your start up and search box or go to run

Type in msconfig.

In the System Configuration window click on the start up tab.

Open Task Manager or if it in in the current window under start up you will see the LogiLDA name and then click disable.

Restart up windows and when it comes up your error message shouldn't show up

share|improve this answer

If you are not comfortable updating the registry manually, use Autoruns (http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx) to delete the entry (go to Logon tab, then under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run should be a Logitech Download Assistant entry that you want to uncheck or delete).

share|improve this answer

I had this issue after upgrade to 8.1, and I do have a Logitech mouse.

  • I navigated to the System32 folder and didn't see the file to delete it.
  • Plugged in the USB dongle for the mouse and the hardware installation set ran.
  • I did a reboot to check and make sure it didn't happen again, and the error is gone.
share|improve this answer

Problem seems to be related to a driver update of the LDA module in Windows 8.1. Go to Computer management -> Human-Interface devices (HID)-> Logitech Download Assistant -> Rollback driver (to restore the last driver version) and the problem disappears.

share|improve this answer

protected by Community Nov 22 '13 at 17:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?