Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All .exe files in F:\Program\Install on my PC are showing Security Warning when clicked: enter image description here

it is shown for apps that don't have valid signature, but apps like CPU-Z (which have digital signature) will show security warning too, but a little different: enter image description here

The problam is that both verified and non verified files will not load after clicking Run, and the error says the program can't access Temp folder. Running exes as administrator will bypass security warning and show the second error (can't access temp...).

I installed a fresh windows, changed the default %Temp% path to c:\ , checked temp permissions, but it didn't work. Now I'm absolutely sure that the problem is not from Temp but F: drive permissions! If i move any of the .exe files in F:\Program\Install (or its sub-directories) to upper roots or another drives, it will execute without any errors!

share|improve this question
    
Could you clarify - is f:\program\install a local or a network location? –  sahmeepee Oct 20 '13 at 20:38
    
it's a local hard disk. i'm not connected to any network. –  Alireza Oct 20 '13 at 21:18
add comment

1 Answer

up vote 1 down vote accepted

Let deal with the CPU ID case first...

This prompt shows up when a file is downloaded from other sources. Right click on the file, click the box Unblock and you will not see that popup again. If you didn't, everything extracted from this zip will have this tag, and this cannot be done with multiple files you select.

Unblock button

Now please screenshot the Security tab of your F:. You may need to reset the permissions if the F: partition was created by another Windows computer/Previous Windows.

By default, the permission would be Authenticated Users, SYSTEM, Administrators (<PC NAME>\Administrators and Users <PC NAME>\Users

UPDATE

Browse to F:\Program, right click Install, Properties. In Security tab, click the Advanced button. Then click button Change Permissions.... Tick both check boxes: "Include inheritable..." and "Replace all child object permissions...", then click OK. it should then rewrite security settings for folders and files within Install.

share|improve this answer
    
thanks for answering. There is no Unblock button for CPU-Z.exe or any other EXE file in that directory! here's the screenshot: img.ir/xKnc.jpg And here's Security tab of F root: img.ir/wKnc.jpg Something strange: i just connected my laptop (with Win8) to this PC (Win7) and shared F:\Install\Program folder on the laptop.then i executed CPU-Z.exe via network, in laptop, and it was executed without any errors even Security Warning!! i'm really surprised now that how can this happen :O –  Alireza Oct 21 '13 at 18:16
    
thanks but ticking does two didnt made any difference. is it possible if i move all files in F: to another drive , format F and then restoring files to F ? –  Alireza Oct 22 '13 at 19:51
    
Don't move them, copy them. Move will copy permission too. When done, format the F: then copy to it. Then delete the temp copy. –  PatricK Oct 23 '13 at 10:41
    
SOLVED ! i copied F: content to another drive, formated F: , and restored its content. now all programs in F: and F:\Program\Install working as well as it was before.i'm just wondering what was the exact problem and where are File Permissions stored! anyway, Thanks Patrick for everything :) –  Alireza Oct 23 '13 at 20:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.