Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I followed these instructions

But I stopped at the very last step. I am asked twice to give user/pass: First, when I connect to the shared "TimeMachine Pi" (all good);

enter image description here

Then, after adding the RPi as capsule I am told

enter image description here

This is my configuration file

; Netatalk 3.x configuration file

; Global server settings
; Name of your computer in apple devices network
hostname = TimeMachine Pi
; IP of your Pi
afp listen =
; logging config
log file = /var/log/netatalk.log
log level = default:info

basedir regex = /home
cnid scheme = dbd
; Display each user home directory in this format
home name = Home: $u

[Time Machine]
; Our Time Machine volume
path = /mnt/TimeMachine
cnid scheme = dbd
file perm = 0660
directory perm = 0770
time machine = yes
share|improve this question

I just stumbled over a similar issue. In my case I forgot to make the directory on the server writable for the user that I was logging in with.

You can try making it group writable for your users:

$ chgrp users /mnt/TimeMachine
$ chmod g+rwX /mnt/TimeMachine
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.