Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu Edge E320, and when I got it, I remember hours of hugs frustration because it was very difficult to get an OS onto it. Eventually, I made to install Ubuntu 12.10. I updated to 13.04 in April - no trouble there.

After the new update to 13.10, the BIOS won't find the OS any more. I just get the message Operating system not found. I have re-installed Ubuntu entirely about 3 times now, then install Linux Mint 15, also 2 times, and every time the result is the same.

I have also tried to manually install GRUB, to force it into an UEFI-compliance mode, but no luck there.

The partition table is GDT. I have /dev/sda1 as ext2, /dev/sda2 as fat16, giving it the uefi_boot flag. I mounted /dev/sda1 into /boot and /dev/sda2 to /boot/efi. Re-installed grub, grub-install, etc etc. I have tried 3 tutorials so far, all with the same result.

I also installed Boot Repair on the Live System. It didn't get me any UEFI-Options like on the screenshots, but I tried anyway. Here is the complete output.

Long story short, I'm really desparate. I really need this notebook for university, and that'll start in a few hours. Been at this all night.

share|improve this question
    
Why is it fat16 and why do you have separate partitions for /boot and /boot/efi. Is it some kind of requirement for UEFI? I have never used UEFI but I always had one ext4 for /boot –  khajvah Oct 21 '13 at 8:07
    
@khajvah Yes, UEFI requires some extra space on the disk for something I never understood. I had to find that out myself when I first installed an OS, took me ages. –  Lambda Dusk Oct 21 '13 at 8:19
add comment

1 Answer

up vote 1 down vote accepted

Your system has incompatible signs of using both a BIOS-mode and an EFI-mode setup, so it's not surprising that it's not booting. I recommend you do the following:

  1. Boot a Linux live CD in EFI mode. If you don't know how to do this, learn. Unfortunately, it's system-specific, but you must generally select the CD-R or USB flash drive boot medium that's described as being "EFI" or "UEFI" in your firmware's boot manager.
  2. Using GParted, make the following changes to /dev/sda2:
    • Remove the bios_grub flag
    • Set the boot flag
    • Create a fresh FAT32 filesystem
  3. Re-run the Boot Repair utility.

If that doesn't help, try this:

  1. Prepare a rEFInd boot manager CD-R or USB flash drive.
  2. Boot the rEFInd medium.
  3. Highlight the icon that corresponds to a Linux kernel (with vmlinuz in the description), but do not hit Enter.
  4. Hit F2 or Insert twice. This will open a text-mode line editor.
  5. Add ro root=/dev/sda4 to the kernel options.
  6. Hit Enter. Linux should boot.
  7. Ensure that /dev/sda2 is mounted at /boot/efi. (It should be if you re-ran Boot Repair in EFI mode earlier.)
  8. Install the rEFInd Debian package.

Thereafter, the computer should boot using rEFInd as the boot manager, but you should not need to edit the kernel options (steps 3-5 above); just highlight a kernel and hit Enter to boot.

share|improve this answer
    
Refind did not install cleanly, it has all the ubuntu-efis I tried before, but it boots, so I can work from there. Many thanks for this tip. –  Lambda Dusk Oct 23 '13 at 7:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.