Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just installed Ubuntu (my first time installing Linux) and I've got my first error. Let me describe my system a bit first. I have a:

EVGA 680i SLI motherboard
4 SATA drives (150GB Raptor with Windows Vista, 64GB SSDnow V with Ubuntu, and 2x1TB RAID-0 WD Caviars)
8GB DDR2 RAM (4x2gb OCZ)

That should be all the info you need right?

Ok, so I installed Ubuntu on the SSD drive (/dev/sdc), its brand new and first install. Everything went smoothly, I downloaded the Ubuntu 64-bit Jaunty (9.04) and burned it to disc, then stuck it in the drive and rebooted. Selected "Install Ubuntu" and followed the steps. When it was done it told me to reboot and remove the disc. I did that.

Now, when I turn on my computer, it says:
*"Grub loading stage 1.5

Grub loading, please wait.....
Error 21"*

It doesn't give me an option to boot into windows, and I can't boot into Ubuntu. So I have two questions.

1) How do I solve this so that I can boot into Ubuntu? I'm able to use the live cd and boot in, that works. 2) How do I boot into Windows (/dev/sda)??

Please bear with me I'm new to linux. How can there be an error here, grub should have been installed properly!


UPDATE:

Followed the instruction here, this didn't work for me, just letting you know what I've tried. In the process I found that the stage1 file points to (hd2,0).


UPDATE 2 - Solved:

Well thats just great... I used Super Grub to fix the boot record, and now everything works, but it (FOR SOME REASON) broke my RAID, so i lost everything on there! Good thing I have it backed up, but thats lame! On top of that, I still don't understand why Ubuntu didn't work from a clean install on a separate free disc!??? This doesn't make sense... ideas are welcome

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Error 21 means that the "selected disk does not exist". So somehow Grub expects to read data from a disk which does not exist. Since this happens before you're shown the dual boot menu, I'd say that the location of the disk which contains stage 2 (?) is not properly configured. I cannot specifically say how to fix that.

Have a look at Super Grub. Store it on a USB stick/key or burn it on a CD/DVD and use it to boot your PC. It will allow you to recover your PC so that the Grub boot menu works again (which will in turn allow you to boot into Linux and/or Windows). Good luck!


By the way, I found this solution at the Ubuntu forums (specifically, this thread). It is generally a good idea to check those forums if you have any Ubuntu-related issues and/or questions. (Not saying that you shouldn't ask here, but you'll have an increased chance of success over there.)

share|improve this answer
    
haha, im trying to but i haven't received my activation email for ubuntu yet, thanks for the advice. I'm reluctant to try those without fully understanding it yet because I have a Windows partition that I don't want to mess with, and a raid that I don't want to mess with. –  GiH Nov 5 '09 at 19:49
    
If it makes you feel more secure, you can boot the Ubuntu live CD and use that to make backups of your Windows partition and/or RAID to some external drive or another PC. –  Stephan202 Nov 5 '09 at 19:52
    
is there no way to just boot into windows now? has grub messed up my ability to boot into windows? –  GiH Nov 5 '09 at 19:54
    
By the way, if the Windows data is your mayor concern, then you can also just pop in the Windows installation disk and let it rewrite the MBR (there's an option for that somewhere). That will make the Ubuntu partition unbootable for now, but at least you have a working PC. You can then fix Grub at a later time. –  Stephan202 Nov 5 '09 at 19:55
    
Link on how to let Windows fix your MBR: helpdeskgeek.com/how-to/fix-mbr-xp-vista –  Stephan202 Nov 5 '09 at 19:57
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.