Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After a recent update, Cygwin bash shell works for any commands that don't require interaction, but if an app needs interaction (for example the python shell), it won't work, the prompt never appears, typing known working commands produces no output.

I've read other places where people suggest mintty, but it behaves the same way.

The shell is completely functional with command line recall, running scripts that don't require interaction etc..., but non-functional as soon as a program asks any or has any prompts.

All of this seems strange since bash is doing exactly what the other apps are doing, interacting with the user, but all other apps seem to be blocked from interacting.

emacs and vi both work, however they seem to be the exceptions to the rule.

cygwin python also works, but windows python does not, and most of my virtualenv's are built of out windows python.

share|improve this question

2 Answers 2

Do you mean Windows interactive apps or Cygwin interactive apps?

Windows and Linux/Unix use different methods to interact with the terminal or console. The default Cygwin terminal is now mintty, which uses the standard Unix tty interface. Windows console apps expect to be able to use the Windows console interface, which is different from the tty interface and not supported by mintty.

If you need to run Windows interactive console apps, use the Windows console or one of the available alternatives that use the console interface. When using Cygwin's mintty, it's best to stick with Cygwin apps, at least the interactive ones.

share|improve this answer

Cygwin Dlls sometimes "go wonky." Did you reboot? Maybe you want to try rebaseall : Running rebaseall on Cygwin or http://cygwin.wikia.com/wiki/Rebaseall

(The wonkyness is based on the pseudo fork() implementation on windows)

share|improve this answer
    
I did reboot, I have now run rebaseall as administrator, and the problem persists. I'm going to reboot once again, and if that doesn't work, I guess I'll pull cygwin out and just reload it from scratch. –  Mark0978 Oct 21 '13 at 14:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.