Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following problem on my Windows 7 computer: I am a member of Administrators, but do not have full Superuser privileges. I have been told that this is by design, and that I need to explicitly "run as administrator" programs where I need Superuser privileges.

How do I do this with control panel?

share|improve this question
2  
You don't. What are you trying to achieve by doing so? –  Oliver Salzburg Oct 21 '13 at 19:11
    
Why not just run the specific programs that you need admin right as an administrator? See this screenshot of what I mean - Screenshot –  Nicholas V. Oct 21 '13 at 19:14
    
My problem is that despite being member of the local administrators group there are still settings I cannot change. For example I can't change in "Control Panel\Hardware and Sound\Power Options\System Settings" the settings for what happens when I press the power button, close the lid etc... My first question about this problem got marked as a duplicate with the suggestion to ask a new question. –  Krist van Besien Oct 22 '13 at 5:49
add comment

3 Answers

Before you go and do these steps, realize that running Control Panel as administrator accomplishes nothing. Since you are already a member of the Administrators group, any changes made in Control Panel run as administrator by default, so running the whole control.exe application as admin is redundant.


You should be able to run the Control Panel as administrator by doing the following:

  1. Create a shortcut to C:\Windows\System32\control.exe.

    enter image description here

  2. Right click the shortcut you made and click Properties, then click the Advanced button.

    enter image description here

  3. Check the box for Run As Administrator.

Opening the shortcut will run the application elevated:

enter image description here


You can also do this from the command line as Tiago Ƈ pointed out in his answer.

share|improve this answer
add comment

Control.exe only launches an Explorer instance and the Explorer can't be run as admin by default. The Elevated-Unelevated Explorer Factory ignores the "Run as Admin" command.

In 2010 I discovered a way to disable the Elevated-Unelevated Explorer Factory

You need to remove/rename the value RunAs in HKEY_CLASSES_ROOT\AppID\{CDCBCFCA-3CDC-436f-A4E2-0E02075250C2}and now the Elevated-Unelevated Explorer Factory is disabled and selecting Run as admin for control.exe starts the Control Panel as admin.

share|improve this answer
add comment

You can use runas(Run As). Example runas /user:Machinename\Administrator "Control.exe".

Or right-click and select Run-As and select the user you want to use.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.