Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had Windows 8 and Linux Mint 15 dual booted on my laptop. When I first installed Linux, I wasn't able to load into because the grub would not show. To fix this, I used boot-repair from a Live CD. This time, I updated to Windows 8.1 and it showed a watermark telling me my secure boot wasn't configured properly. I then went and enabled secure boot (BIOS) and I believe it was after that that the Grub would not show once again. I tried to boot from a Linux CD again but when I try, it gives me the following errors:

error: failure reading sector 0x0 from 'hd1'
error: you need to load the kernel first.

Press any key to continue...

Before, it was giving me an error with sector 0x6d200 or something instead of 0x0. I am completely unsure of what to do. I do not know what other details to give except that this my have happened after I enabled secure boot, and I actually clicked reset to default setting so I am unsure if any other settings were changed in the BIOS menu.

share|improve this question
    
hi1 suggests your hard drive. have you checked the boot order in the bios? – bryan Oct 22 '13 at 3:32
    
EFI Boot? You may have to reinstall grub. – Grizly Oct 22 '13 at 3:37
    
@bryan Legacy boot order shows: Notebook Hard Drive, Internet CD Drive, USB Diskette on Key/USB Hard Disk, USB CD ROM Drive, ! Network Adapter in that order – Jefferson Steelflex Oct 22 '13 at 3:40
    
@Grizly That's what I tried to do but I can't even boot into the Live CD – Jefferson Steelflex Oct 22 '13 at 3:40
    
You'd need to change the boot order to get to the liveCD (based on that list), I googled that first error, and it seems common to every distro! Can you turn off UEFI for the DVD drive? This might help (once its fixed: help.ubuntu.com/community/UEFI#Converting_Ubuntu_into_EFI_mode) – Grizly Oct 22 '13 at 3:53

Turn off Secure Boot.

Linux Mint doesn't support it yet.

share|improve this answer
    
I turned it off, the Live CD would give me the same error. – Jefferson Steelflex Oct 22 '13 at 15:00
    
You commented above: "I changed it into legacy mode. This allowed me to run the live linux mint cd and reinstall grub using boot-repair" Is this ambiguous? I don't understand the problem then. – Grizly Oct 23 '13 at 22:51
    
So, im having this issue too on an Hp Arch Linux laptop, runing system rescue cd. error: failure reading from sector 0x...... from cd0, you need to load the kernel first. And thats exactly why im loading the cd in the first place. STUCK. Answers Please? – Brian Thomas Aug 18 '15 at 19:57
    
Hi Brian, I'm sure this isn't the place for this, but you can use something like support.hp.com/us-en/document/c03653226 but in reverse to disable Secure Boot from your device. – Grizly Aug 19 '15 at 0:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .