Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I sometimes gets an ip address of received for my laptop (instead of one in the 10.0.0.x range). I thought it was a problem with my Ubuntu system, but after I dual-booted I got the same problem under Windows Vista with the same laptop.

What's the problem, why does it happens only sometimes, and how can it be solved?

For the record: I'm using a Linksys WRT610N wireless router.

share|improve this question
up vote 3 down vote accepted

A 169.254.x.x IP is self-assigned. It means that you could not be assigned an IP by the DHCP server (which in your case is probably the router). Have you tried rebooting the router, and then the computer? Usually this takes care of it. If you have to do it repeatedly, you may want to see if there is a firmware update out for your router.

This could also potentially be caused by a hardware or software problem on your laptop, so if this doesn't work, please let us know.

share|improve this answer
Rebooting the laptop sometimes helps, which make the problem difficult to pinpoint. Maybe I have to check the DHCP options of the router. – Roalt Nov 6 '09 at 6:46
I would see if there is a firmware update for your router – MDMarra Nov 6 '09 at 6:55
The order is specifically Modem, router, computer. I've had to do it many times until I got a good router & modem. – Dave May 4 '10 at 23:23
@Dave - what are you saying? A modem doesn't factor in to a 169.254.x.x IP if the router is the DHCP server. If the router is functioning properly as a DHCP server, but the modem is dead you will still get a proper IP address, you just won't be able to connect to the Internet. – MDMarra May 5 '10 at 2:15
@Mark - that wasn't my experience. For years I needed to do all or it didn't work correctly. Any step left out and no-go. – Dave May 5 '10 at 20:21

That's a link local address. Means your machine is having trouble getting a valid IP address assigned.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.