Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have asked a similar question before and no one was able to help me but I think it was because I wasn't phrasing it properly. This is a better restatement of the question. I have Windows 8 and Linux Mint dual booted on my pc. When I tried to boot the Linux from a CD ROM only, it would give me the following error:

error: failure reading sector 0x0 from 'hd1'
error: you need to load the kernel first.

Press any key to continue...

The Linux Mint works fine but otherwise, but it gives this error when I try to boot from CD. The boot Linux from CD only worked when I changed the Windows to Legacy mode in the BIOS settings. When I changed it back to UEFI, it would give the same error. Why is this? How can I fix it? I am somewhat new so is there anything else I should know about all of this?

NOTE: I changed the Linux into UEFI mode using boot-repair but that still did not solve the problem when I tried to boot from CD ROM.

share|improve this question
    
help.ubuntu.com/community/UEFI and any of the 1000s of results for linux UEFI you can find on google. –  terdon Oct 22 '13 at 15:12
    
Do you know if Mint even supports UEFI. I can only assume the problem is that there isn't EFI boot information on the "Live CD" –  Ramhound Oct 22 '13 at 15:13
    
@terdon I used that link and I used boot-repair to change the Linux into UEFI mode, the Live CD still didn't work which is why I am asking here. –  Vee Oct 22 '13 at 15:16
    
@Ramhound I changed the Linux into UEFI using boot-repair –  Vee Oct 22 '13 at 15:17
    
@Vee please mention the things you have tried in your question, we can't know what you've done. Now, what do you mean you changed Linux to UEFI? You mean your installed system? Did you "In your BIOS, disable QuickBoot/FastBoot and Intel Smart Response Technology (SRT). If you have Windows8, also disable FastStartup." as suggested by the guide I linked to? –  terdon Oct 22 '13 at 15:22

1 Answer 1

It sounds like the Mint CD you're using either has buggy EFI support or that support has an incompatibility with your particular computer. The main Mint distribution has long supported EFI, but EFI support is new enough that bugs and incompatibilities are far from rare. It's possible you could overcome this problem by upgrading your computer's firmware to the latest version, by using a different version of Mint (you don't say which one you're using), by preparing a USB flash drive and booting from it, or by modifying the boot loader on a USB flash drive. If you want more practical advice, please say what version of Mint you're using and what your computer's make and model are. Posting your problem to the Mint forum might also be in order.

Fortunately, for most purposes using an emergency Linux CD in BIOS/CSM/legacy mode is not a problem, even if your regular installation boots in EFI mode. The main reasons to want to boot a live CD in BIOS/CSM/legacy mode are to install the OS or to manage a boot loader setup using the efibootmgr utility. Based on your question, the former task is already done (although that begs the question of how you did it). Managing boot loaders can be done using the Windows bcdedit command, using an EFI shell's bcfg command, or sometimes using an EFI's built-in user interface. See the Installing rEFInd Manually section of the rEFInd documentation for more information on most of these tools. (The same principles apply to other boot programs, not just to rEFInd.)

share|improve this answer
    
My Mint's version is 15 so it's the latest one. It's an HP Envy 1225-dx, runs on an i5-3230m, 8gb of RAM. And yes, the reason this was a concern to me was this problem did not occur when I first installed the Linux. I do not remember having to change the boot into Legacy. And yes, I will check out Mint forum. –  Vee Oct 24 '13 at 14:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.