Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ive been working on some command line stuff with an external developer through team viewer for work, to interact with th CL i use terminal on OSX, when working with the developer i was always watching what they were doing and i also have all the bash history.

Usually upon opening terminal i get something like this

Last login: Tue Sep 17 21:33:02 on ttys001
You have mail.
unknown-5c:00:00:00:00:00:~ sam$

(note ive replaced some characters in the last line with 00)

But today when i opened up terminal and i get this

Last login: Mon Oct 21 16:49:35 on ttys000
You have mail.
richies-ipad:~ sam$ 

Note it now says richies-ipad - any idea why this is ? I dont know any one called richie let alone let them have access to my machine. Is this something to be worried about - the fact that someone has enough access to change that ?

Upon rebooting the machine i get this

Last login: Tue Oct 22 17:15:51 on console
You have mail.
richies-ipad:~ sam$ 

Note richies-ipad is still there.

By the way this is on my local machine.

Also what does the ttys001 part on the first line mean ?

share|improve this question
    
Have you rebooted the system? The hostname should revert to the stored configuration when it's rebooted. –  Darth Android Oct 22 '13 at 15:37
    
Ill try it now, and let you know how i get on –  sam Oct 22 '13 at 16:01
    
I rebooted, but am still getting the same richies-ipad part. –  sam Oct 22 '13 at 16:22
    
When i took my computer home and ran it i got back the unknown-5c:00:00:00:00:00:~ sam$ but now im back at the office using the office wifi, its reverted back to richies-ipad:~ sam$ –  sam Oct 23 '13 at 10:48
1  
The "ttys001" is a reference back to when we actually had teletype terminals -- it's essentially "terminal input device #1". There are pictures on the answer at stackoverflow.com/questions/4532413/what-is-tty-on-freebsd . –  Debra Oct 23 '13 at 21:31

1 Answer 1

This is nothing to worry about from a security standpoint -- it does not mean that someone named richie has access to your machine. It may indicate networking troubles, though. In particular, it may be difficult for you to access that machine over a network without explicitly knowing the IP.

Hostnames

The text you're seeing there is the hostname for your machine, which may be set by your DNS server. The fact that you're seeing richies-ipad there may mean that your DNS server thinks your current IP belongs to that machine.

Check your hostname from the terminal by typing hostname at the prompt.

Setting the hostname

The easiest way to set the hostname for your machine is to rely on Mac OS X's behavior of setting the hostname equal to the computer name by default. Go to Apple Menu > System Preferences > Sharing and type your desired hostname into the Computer Name field.

To more explicitly set the hostname, you may do so from the terminal, using the hostname command (i.e. hostname <myhostname>. As noted in man hostname, though, this strategy will not survive a reboot, and you're better off using scutil --set HostName <myhostname> to set it.

See This article for a more thorough explanation of the various computer names under Mac OS X.

share|improve this answer
    
Whats odd is that when i go to Apple Menu > System Preferences > Sharing i get sam’s MacBook Pro even though in terminal & when i run hostname im still getting richies-ipad:~ sam$ hostname richies-ipad –  sam Oct 23 '13 at 10:50
    
Right -- you're still getting a hostname from DNS. Have you tried setting your hostname explicitly with hostname or scutil? –  spinup Oct 23 '13 at 13:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.