Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My issue is similar to the one mentioned here: Disable spell checking in Internet Explorer 10 (Windows 8)

I am using Windows 8.1 Pro 64-bit


What I've tried already:

Deactivating the spelling options:

From the following, borrowed screenshot from the old Windows 8 (my interface is German, therefore I couldn't create one myself), I have turned both options off and restarted IE. It's still "correcting" my texts.

PC Settings

Searching for 'spelling correction' addons:

The indicated option in the following borrowed screensnot does not exist on my PC. IE Addons

Is there any way of disabling it? I prefer a canonical solution if one is available. If not, I am also interested in registry hacks or other solutions.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

So this issue is a permissions issue. When running IE in EPM mode, regkeys are being blocked at location HKCU\Software\Microsoft\TabletTip\1.7 due to ALL APPLICATION PACKAGES not being added to permissions. So a way to fix this (please respond if this does not work), is to go to

  1. Win key

  2. type "regedit" and click on the regedit application

  3. Navigation to HKey_CURRENT_USER\Software\Microsoft\TabletTip\1.7

  4. Right click on the 1.7 directory

  5. Select "Permissions..."

  6. Click Add

  7. Click Advanced

  8. For Locations choose your computer

  9. Click Find Now

  10. Select ALL APPLICATION PACKAGES and click OK

A fix will be coming down, but in the meantime, this is correct fix

share|improve this answer
    
Your solution worked beautifully, thanks! It would be nice if you could post the link to the fix once it becomes available! –  ComFreek Nov 26 '13 at 15:33

From How to Disable Built-in Spell Checker Feature :

  1. Move your mouse cursor to top-right or bottom-right corner of screen to access Charms Bar and click on Settings option.
  2. Now click on Change PC settings option given at the bottom.
  3. It'll open Metro Control Panel or PC Settings page. Click on General section given in left-hand side in Windows 8. If you are using Windows 8.1, click on PC & devices -> Typing.

    image

  4. Now in right-side, turn off following 2 options:
    Autocorrect misspelled words
    Highlight misspelled words

  5. That's it. It'll disable spell checker feature in Internet Explorer as well as the whole operating system.

share|improve this answer
    
It's really strange because they are already turned off on my system, but IE keeps correcting my texts. –  ComFreek Oct 25 '13 at 12:02
    
Is it happening on both desktop and modern versions of IE11? –  harrymc Oct 25 '13 at 12:56
    
Yes, it's happening on both versions. –  ComFreek Oct 25 '13 at 12:59
    
Have you tried IE safe mode? –  harrymc Oct 25 '13 at 13:03
    
Do you mean iexplore.exe -extoff? It shows the same behavior. –  ComFreek Oct 25 '13 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.