Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a REALLY weird problem with either my network or my OS.

Last week I've suddenly had difficulties loading some websites or even more odd some parts of different websites. For example, I could load gmail.com, login and view the list of emails in my inbox but when I clicked one of them it would just time out. Another example is http://www.ynet.co.il, I can view the home page but going into any one of the articles fails (times out).

I've tried Chrome, Firefox and Opera, all fail the same way.

If I take a URL of a page I cannot load via the browser and try to wget it though the console I get the file just fine.

I've formatted my machine (Used to run Ubuntu 13.04) and installed Mint Linux this time, it worked fine for a few days and now, again, having the same exact issues.

Important to note that I have other machines connected either directly or via Wi-Fi to the router and they are all working fine (two win7 machines and 1 raspberry pi).

Another strange behavior is that I can ftp or ssh to remote machines but cannot send files via ftp (times out) even if I set passive mode ON and when using ssh I can do just about anything but I cannot paste text into the remote machine, for example if I nano a file on the remote machine and try to paste anything from my clipboard it freezes.

What I've tried so far:

  1. Disable IPv6 on the networking admin (and on firefox disabling ipv6 on the about:config page)
  2. Changing the port and the network cable
  3. I went to the store and bought a new standalone PCIe network adapter
  4. Connected my win7 laptop using the same cable and router port (sites that were not working on my Mint are working just fine on the win7 machine)
  5. Loaded Mint from a livecd, got the same result
  6. Tried changing the MTU (was 1500, tried 1492)

Some observations:

  1. When I clear my browser cache and go to facebook.com for example, the homepage loads but I fail to load any profile/group page. If I refresh facebook.com homepage a couple of times it stops and fails to load until I clear my browser cache. I changed the chrome cache folder permissions to 0777 but that did not help.

  2. When I run netstat -n I see A LOT of connections that are in 'FIN_WAIT' mode (I'm guessing that's when I try to refresh pages that are not working and timing out), I have no idea what it means or if it helps anyone figure out what's wrong.

  3. The sites that are not loading correctly are always that same, they don't vary or anything and they fail to load exactly the same way on all three browsers that I've tried.

  4. When I Googled 'Ubuntu some sites not loading' I see a huge amount of complaints just like mine, but none of them that I could find actually says what the problem is or how they fixed it.

Technical stuff:

  1. netstat -n
  2. ps aux
  3. netstat -nr
share|improve this question

1 Answer 1

I too have the same problem. First faced this problem with Linux Mint , so I tried Ubuntu & Fedora . Even with Ubuntu & Fedora I faced the same problem . But when I connectthe same internet connection with Windows 8 Laptop it works fine.

Here are few solutions which might be useful to you.

http://forums.linuxmint.com/viewtopic.php?f=150&t=148462

share|improve this answer
1  
Can you summarize what is at the link within your answer in case the linked page goes dead? –  jonsca Dec 6 '13 at 11:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.