Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a desktop, 3 laptops, and a mobile. I want to able able to connect to one another with my Netgear WGR614. My desktop has internet via 3G, that I'd like to share with other nodes. I'm able to do this by connecting it to internet port of my router, but that prevents me from accessing laptops from my desktop (router stops me).

Here is one more setup I tried:
Connected all computers as clients to my router, and changed default route in all computers as my desktop's IP. This works but is too messy I need to change the configs time and again in laptops. Too frustrating to do them on mobile devices.

I use Ubuntu 12.04 on my desktop. Cleints include Windows XP, Ubuntu 12.04, Mac OS, and Android.

Please help me regarding this.

Thanks :)

P.S. My 3G Internet connection is fastest I can get at this location (12-14 Mbps download and 5-6 Mbps upload). By the way what the pic shows is the case where we use all the laptops. We generally don't use all of them at a time and so it should be fine.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

If I understand correctly everthing would work, if the default route of all computers would point to your desktop. If I interpret the documentation at http://kb.netgear.com/app/answers/detail/a_id/19852 correctly, your router unfortunately doesn't support to adjust its DHCP to provide the needed information so you'd have to run a DHCP server elsewhere.

If your desktop is always on when you need your LAN connections, you could set it up on your desktop. You would need to configure a fixed IP address for ethernet on your desktop and install dhcp-server as shown in https://help.ubuntu.com/community/dhcp3-server - the simple setup, not multiple networks. option routers would be your local desktop ip address, for option domain-name-servers you could use google's servers at 8.8.8.8 and 8.8.4.4 if you don't want to run your own on your desktop. Don't forget to disable the router's DHCP as shown in the document above.

share|improve this answer

It looks to me from looking at your diagram that you are connecting to the router from the desktop to the wan port , That is not the way to do it hook it to one of the lan ports like the rest of the computers. configure the router to disable dhcp and if the router has a way to enable access point enable that

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.