Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set up a program to always run as an administrator using the Compatability setting in Properties, which is necessary as the program always require administrator rights. Is there a way to make so that the User Account Control prompt does not always pop up and require me to confirm that I want to run this as an administrator? I am on an administrator account. I know I can simply turn off all User Account Control notifications, but I would rather not do this for security purposes; rather, I just want UAC settings to remember the choice I made regarding running the program as an administrator but not prompt me to confirm it.

This is an example of what I want, but that was made for Windows 7 and I'm not sure how well it work in 8.1.

share|improve this question
    
What you want requires a prompt –  Ramhound Oct 23 '13 at 2:00
    
-1 re your last line, you're not sure how well it will work in windows 8.1? try it –  barlop Oct 24 '13 at 18:26
    
even when given an answer of what to try, you don't know whether it will work unless you try it. that guide you link to has lots of pictures and you haven't struggled with any of it 'cos you haven't tried it. you haven't found it daunting you just haven't tried it. You could've tried it in the time it took to write your question. And if you tried it and it hadn't worked then you could've written a far better more well informed question. –  barlop Oct 24 '13 at 18:36

5 Answers 5

up vote 6 down vote accepted

The Task Scheduler trick you mention still works fine in Windows 8.x. I use it daily. You can use it without any issues.

share|improve this answer
2  
+1 to cancel the idiot that downvoted you without comment. –  barlop Oct 24 '13 at 18:27

Open Windows PowerShell (open it as an Administrator) and Run below registry settings:

Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "0"
share|improve this answer
1  
-1 because he said he doesn't want to disable the UAC. –  magicandre1981 Feb 4 '14 at 18:42

The best way I found was to go to the EXE file, right-click and select Troubleshoot compatibility. There you'll have an option to select that the program requires additional permissions at which point the program will be changed to run as administrator. Save the changes and you're all set.

share|improve this answer
    
this triggers the UAC prompt again which he wants to avoid ;) –  magicandre1981 Jul 24 '14 at 4:10

Click here for a few options:

The first involves creating a link to a task you will create using task manager for the application. The task is set to launch immediately and with elevated privileges and the other solutions rely on 3rd party software.

Search Words: uac suppress prompt

share|improve this answer

You can use Microsoft's Windows Assessment and Deployment Kit(ADK)'s Compatibility Administrator. You can find a good starting tutorial here.

share|improve this answer
1  
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Mokubai Aug 12 '14 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.